diff mbox series

[bug#55436,3/3] gnu: public-inbox: Update to version 1.8.0

Message ID 20220515220230.504057-3-bauermann@kolabnow.com
State Accepted
Headers show
Series Update public-inbox to 1.8.0 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann May 15, 2022, 10:02 p.m. UTC
Some fixes are needed in both the testsuite and the package itself before
tests can pass so disable them for now.

Also, the lei command needs curl to work, so add it to the PATH in
‘wrap-program’.

* gnu/packages/mail.scm (public-inbox)[version]: Change to 1.8.0.
[source]: Update hash.
[arguments]<#:tests?>: Set to #f.
[arguments]<#:phases>{wrap-programs}: Add curl to PATH.
[inputs]: Add curl and perl-socket-msghdr.
---
 gnu/packages/mail.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

Comments

Kyle Meyer May 16, 2022, 2:13 a.m. UTC | #1
Thiago Jung Bauermann via Guix-patches via writes:

> [...]
> [inputs]: Add curl and perl-socket-msghdr.
> ---
> [...]
>      (inputs
>       (list bash-minimal
> +           curl
>             git
>             perl-dbd-sqlite
>             perl-dbi

I think it'd be good to add libgit2 as well.
Thiago Jung Bauermann May 16, 2022, 2:42 a.m. UTC | #2
Hello Kyle,

Thank you for the feedback.

Kyle Meyer <kyle@kyleam.com> writes:

> Thiago Jung Bauermann via Guix-patches via writes:
>
>> [...]
>> [inputs]: Add curl and perl-socket-msghdr.
>> ---
>> [...]
>>      (inputs
>>       (list bash-minimal
>> +           curl
>>             git
>>             perl-dbd-sqlite
>>             perl-dbi
>
> I think it'd be good to add libgit2 as well.

Ah, I wasn't aware of that. I'll wait a bit to see if there are more
comments and spin a v2 with the change.
Ludovic Courtès May 24, 2022, 2:47 p.m. UTC | #3
Hi,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

> Ah, I wasn't aware of that. I'll wait a bit to see if there are more
> comments and spin a v2 with the change.

I haven’t tested it but at first sight it LGTM.

Ludo’.
Thiago Jung Bauermann May 25, 2022, 3:21 p.m. UTC | #4
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
>
>> Ah, I wasn't aware of that. I'll wait a bit to see if there are more
>> comments and spin a v2 with the change.
>
> I haven’t tested it but at first sight it LGTM.

Thank you for your review!

I tried adding both libgit2 and pkg-config (which public-inbox uses to
find the library) to the package inputs, but unfortunately the resulting
package doesn't retain a reference to libgit2, so I don't think it
worked:

--8<---------------cut here---------------start------------->8---
popigai ⸤env⸥: ./pre-inst-env guix gc --references \
  $(./pre-inst-env guix build --no-grafts public-inbox) \
  | grep git
/gnu/store/afr6sh2vap4vdvj09s1q0rmcc3gl51rc-git-2.36.0
popigai ⸤env⸥: 
--8<---------------cut here---------------end--------------->8---

There's more work to be done to make Perl's Inline::C mechanism work in
Guix's environment. To be honest, I won't be able to work on that.

Would it be possible to commit these patches as they are now, and then
if someone can make public-inbox use libgit2 then that change can be
submitted as a separate patch?
Ludovic Courtès June 1, 2022, 8:45 p.m. UTC | #5
Hi Thiago,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

> Would it be possible to commit these patches as they are now,

Definitely, done!

> and then if someone can make public-inbox use libgit2 then that change
> can be submitted as a separate patch?

Sure, we can keep that as future work.  :-)

Thanks,
Ludo’.
Thiago Jung Bauermann June 1, 2022, 11:03 p.m. UTC | #6
Hello Ludo,

Ludovic Courtès <ludo@gnu.org> writes:

> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
>
>> Would it be possible to commit these patches as they are now,
>
> Definitely, done!

Awesome, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 0728d65d1d10..781c3bd028ff 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4087,7 +4087,7 @@  (define-public l2md
 (define-public public-inbox
   (package
     (name "public-inbox")
-    (version "1.6.1")
+    (version "1.8.0")
     (source
      (origin (method git-fetch)
              (uri (git-reference
@@ -4095,11 +4095,12 @@  (define-public public-inbox
                    (commit (string-append "v" version))))
              (sha256
               (base32
-               "0mlwnp5knr7rk9kv8grlh342wsq2193m22zs83cjn9p7x9r2x5f9"))
+               "0xni1l54v1z3p0zb52807maay0yqabp8jgf5iras5zmhgjyk3swz"))
              (file-name (git-file-name name version))))
     (build-system perl-build-system)
     (arguments
-     '(#:phases
+     '(#:tests? #f
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'qualify-paths
            (lambda* (#:key inputs #:allow-other-keys)
@@ -4132,13 +4133,15 @@  (define-public public-inbox
                     ;; 'git' is invoked in various files of the PublicInbox
                     ;; perl module.
                     `("PATH" ":" prefix
-                      (,(dirname (search-input-file inputs "/bin/git"))))))
+                      (,(dirname (search-input-file inputs "/bin/git"))
+                       ,(dirname (search-input-file inputs "/bin/curl"))))))
                 (find-files (string-append out "/bin")))))))))
     (native-inputs
      (list ;; For testing.
            lsof openssl))
     (inputs
      (list bash-minimal
+           curl
            git
            perl-dbd-sqlite
            perl-dbi
@@ -4151,6 +4154,7 @@  (define-public public-inbox
            perl-plack-middleware-reverseproxy
            perl-plack
            perl-search-xapian
+           perl-socket-msghdr
            perl-timedate
            perl-uri-escape
            perl-inline-c