diff mbox series

[bug#52953,3/3] gnu: openmw: Update to 0.47.0.

Message ID 20220102160250.17874-3-felgru@posteo.net
State Accepted
Headers show
Series Update openmw to 0.47.0. | expand

Commit Message

Felix Gruber Jan. 2, 2022, 4:02 p.m. UTC
* gnu/packages/game-development.scm (openmw): Update to 0.47.0.
  [arguments]: Add "-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON" to
  configure-flags.
  [inputs]: Use new simplified format. Add new dependencies lz4 and
  recastnavigation. Replace bullet with bullet-double-precision.
---
 gnu/packages/game-development.scm | 28 ++++++++++++++++------------
 1 file changed, 16 insertions(+), 12 deletions(-)

Comments

Leo Famulari Jan. 3, 2022, 4 a.m. UTC | #1
On Sun, Jan 02, 2022 at 04:02:50PM +0000, Felix Gruber wrote:
> * gnu/packages/game-development.scm (openmw): Update to 0.47.0.
>   [arguments]: Add "-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON" to
>   configure-flags.
>   [inputs]: Use new simplified format. Add new dependencies lz4 and
>   recastnavigation. Replace bullet with bullet-double-precision.

LGTM. Just waiting on responses to my messages about the first and
second patches.
Felix Gruber Jan. 3, 2022, 7:37 p.m. UTC | #2
Hi Leo,

here's the updated patchset incorporating your remarks.

On 1/3/22 4:59 AM, Leo Famulari wrote:
> On Sun, Jan 02, 2022 at 04:02:48PM +0000, Felix Gruber wrote:
>> +      (synopsis "navigation system for games")
> 
> The linter should warn that the "synopsis should start with an
> upper-case letter or digit".

You're right, I should definitely make a habbit of running guix lint
before sending my patches!

>> * gnu/packages/game-development.scm (bullet-double-precision): New
>>   variable.
> 
> I'm curious, did you try making this change in the 'bullet' package
> itself, and then rebuilding the packages that depend on it? It would be
> nice to avoid making another package variant if it's not necessary.

I've incorporated the double precision configure flag in the bullet
package now, and all its dependent packages still seem to build
correctly.

Felix Gruber (3):
  gnu: Add recastnavigation.
  gnu: bullet: Build with double precision arithmetics.
  gnu: openmw: Update to 0.47.0.

 gnu/packages/game-development.scm | 82 ++++++++++++++++++++++++++-----
 1 file changed, 70 insertions(+), 12 deletions(-)
Leo Famulari Jan. 3, 2022, 8:14 p.m. UTC | #3
On Mon, Jan 03, 2022 at 07:37:20PM +0000, Felix Gruber wrote:
> I've incorporated the double precision configure flag in the bullet
> package now, and all its dependent packages still seem to build
> correctly.

Great! I added more detail to the code comment in bullet and pushed as
92faad0adb93b8349bfd7c67911d3d95f0505eb2
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c19875fb2f..97f4eec2c4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2020-2021 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1777,7 +1778,7 @@  of use.")
 (define-public openmw
   (package
     (name "openmw")
-    (version "0.46.0")
+    (version "0.47.0")
     (source
      (origin
        (method git-fetch)
@@ -1787,24 +1788,27 @@  of use.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0rm32zsmxvr6b0jjihfj543skhicbw5kg6shjx312clhlm035w2x"))))
+         "19mcbnjl4279qalb97msf965bjax48mx1r1qczyvwhn28h6n3bsy"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; No test target
        #:configure-flags
-       (list "-DDESIRED_QT_VERSION=5")))
+       (list "-DDESIRED_QT_VERSION=5"
+             "-DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON")))
     (native-inputs
      (list boost doxygen pkg-config))
     (inputs
-     `(("bullet" ,bullet)
-       ("ffmpeg" ,ffmpeg)
-       ("libxt" ,libxt)
-       ("mygui" ,mygui-gl)              ; OpenMW does not need Ogre.
-       ("openal" ,openal)
-       ("openscenegraph" ,openmw-openscenegraph)
-       ("qtbase" ,qtbase-5)
-       ("sdl" ,sdl2)
-       ("unshield" ,unshield)))
+     (list bullet-double-precision
+           ffmpeg
+           libxt
+           lz4
+           mygui-gl              ; OpenMW does not need Ogre.
+           openal
+           openmw-openscenegraph
+           qtbase-5
+           recastnavigation
+           sdl2
+           unshield))
     (synopsis "Re-implementation of the RPG Morrowind engine")
     (description
      "OpenMW is a game engine which reimplements and extends the one that runs