diff mbox series

[bug#52953,2/3] gnu: Add bullet-double-precision.

Message ID 20220102160250.17874-2-felgru@posteo.net
State Accepted
Headers show
Series Update openmw to 0.47.0. | expand

Commit Message

Felix Gruber Jan. 2, 2022, 4:02 p.m. UTC
This is a variant of bullet built with a configure flag for double
precision arithmetics required by openmw 0.47.

* gnu/packages/game-development.scm (bullet-double-precision): New
  variable.
---
 gnu/packages/game-development.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Leo Famulari Jan. 3, 2022, 3:59 a.m. UTC | #1
On Sun, Jan 02, 2022 at 04:02:49PM +0000, Felix Gruber wrote:
> This is a variant of bullet built with a configure flag for double
> precision arithmetics required by openmw 0.47.
> 
> * gnu/packages/game-development.scm (bullet-double-precision): New
>   variable.

I'm curious, did you try making this change in the 'bullet' package
itself, and then rebuilding the packages that depend on it? It would be
nice to avoid making another package variant if it's not necessary.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1f7d05f61c..c19875fb2f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -172,6 +172,16 @@ 
 is used in some video games and movies.")
     (license license:zlib)))
 
+(define-public bullet-double-precision
+  (package
+    (inherit bullet)
+    (arguments
+     (substitute-keyword-arguments (package-arguments bullet)
+       ((#:configure-flags cf)
+        `(cons "-DUSE_DOUBLE_PRECISION=ON" ,cf))))
+    (synopsis (string-append (package-synopsis bullet)
+                             " (with double precision)"))))
+
 (define-public deutex
   (package
    (name "deutex")