diff mbox series

[bug#50664,core-updates-frozen,v2] gnu: curl: Respect #:tests?.

Message ID d09fb1addde0001d8c2303ea067839ed34d5553d.1632076975.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#50664,core-updates-frozen,v2] gnu: curl: Respect #:tests?. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen Sept. 19, 2021, 6:46 p.m. UTC
* gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
---
Changes from v1:

* Do not provide a default value for tests?, since gnu-build-system provides
  one.

--
Sarah
 gnu/packages/curl.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)


base-commit: 8613652f3f80105f35db13d6d9308257bbff8474

Comments

Maxim Cournoyer Nov. 12, 2021, 5:52 a.m. UTC | #1
Hello,

Sarah Morgensen <iskarian@mgsn.dev> writes:

> * gnu/packages/curl.scm (curl)[arguments]<#:phases>{check}: Respect #:tests?.
> ---
> Changes from v1:
>
> * Do not provide a default value for tests?, since gnu-build-system provides
>   one.
>
> --
> Sarah
>  gnu/packages/curl.scm | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
> index 063a919700..4c90c7b301 100644
> --- a/gnu/packages/curl.scm
> +++ b/gnu/packages/curl.scm
> @@ -124,16 +124,16 @@
>               (rename-file (string-append out "/share/man/man3")
>                            (string-append doc "/share/man/man3"))
>               #t)))
> -        (replace
> -         'check
> -         (lambda _
> -           (substitute* "tests/runtests.pl"
> -             (("/bin/sh") (which "sh")))
> +        (replace 'check
> +          (lambda* (#:key tests? #:allow-other-keys)
> +            (substitute* "tests/runtests.pl"
> +              (("/bin/sh") (which "sh")))
>  
> -           ;; The top-level "make check" does "make -C tests quiet-test", which
> -           ;; is too quiet.  Use the "test" target instead, which is more
> -           ;; verbose.
> -           (invoke "make" "-C" "tests" "test"))))))
> +            (when tests?
> +              ;; The top-level "make check" does "make -C tests quiet-test", which
> +              ;; is too quiet.  Use the "test" target instead, which is more
> +              ;; verbose.
> +              (invoke "make" "-C" "tests" "test")))))))
>     (synopsis "Command line tool for transferring data with URL syntax")
>     (description
>      "curl is a command line tool for transferring data with URL syntax,
>
> base-commit: 8613652f3f80105f35db13d6d9308257bbff8474

This got merged in core-updates-frozen as
460d6aca0c9a8f8443d50e5a5cf2bf9841bcc559; and I just noticed I had
forgotten to put my signed-off-by line; apologies.

Thank you!

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 063a919700..4c90c7b301 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -124,16 +124,16 @@ 
              (rename-file (string-append out "/share/man/man3")
                           (string-append doc "/share/man/man3"))
              #t)))
-        (replace
-         'check
-         (lambda _
-           (substitute* "tests/runtests.pl"
-             (("/bin/sh") (which "sh")))
+        (replace 'check
+          (lambda* (#:key tests? #:allow-other-keys)
+            (substitute* "tests/runtests.pl"
+              (("/bin/sh") (which "sh")))
 
-           ;; The top-level "make check" does "make -C tests quiet-test", which
-           ;; is too quiet.  Use the "test" target instead, which is more
-           ;; verbose.
-           (invoke "make" "-C" "tests" "test"))))))
+            (when tests?
+              ;; The top-level "make check" does "make -C tests quiet-test", which
+              ;; is too quiet.  Use the "test" target instead, which is more
+              ;; verbose.
+              (invoke "make" "-C" "tests" "test")))))))
    (synopsis "Command line tool for transferring data with URL syntax")
    (description
     "curl is a command line tool for transferring data with URL syntax,