diff mbox series

[bug#51739,2/3] gnu: Use license: prefix.

Message ID M5E9ow1MQ1Sa0sGmeKvrYIpbDY1IbRszq-AyliT0itqrCa_6p1Wo4T5_69970MvcguLImkm0A6nUisPwHHktEKgYgIgAQhef4fQLKWWzXvs=@protonmail.com
State Accepted
Headers show
Series [bug#51739,1/3] gnu: Add realmd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 10, 2021, 3:07 a.m. UTC
* gnu/packages/time.scm (time, python-pytimeparse, python-pytzdata,
  python2-tzdata, python-pytz, python2-pytz, python-pendulum, python-dateutil,
  python2-dateutil, python-parsedatetime, python2-parsedatetime,
  python-ciso8601, python-tzlocal, python-isodate, python2-isodate,
  python-iso8601, python2-iso8601, python-monotonic, python2-monotonic,
  python-pyrfc3339, python2-pyrfc3339, python-arrow, python-aniso8601,
  python2-aniso8601, datefudge, countdown) [license]: Prefix with license:.

--
2.33.1

Comments

Leo Famulari Nov. 10, 2021, 10:26 p.m. UTC | #1
On Wed, Nov 10, 2021 at 03:07:46AM +0000, phodina via Guix-patches via wrote:
> * gnu/packages/time.scm (time, python-pytimeparse, python-pytzdata,
>   python2-tzdata, python-pytz, python2-pytz, python-pendulum, python-dateutil,
>   python2-dateutil, python-parsedatetime, python2-parsedatetime,
>   python-ciso8601, python-tzlocal, python-isodate, python2-isodate,
>   python-iso8601, python2-iso8601, python-monotonic, python2-monotonic,
>   python-pyrfc3339, python2-pyrfc3339, python-arrow, python-aniso8601,
>   python2-aniso8601, datefudge, countdown) [license]: Prefix with license:.

Is there a reason to make this change? Usually we only prefix the
license field when necessary.
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index b60fab5db5..ce0f644194 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -50,7 +50,7 @@  (define-module (gnu packages time)
   #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix git-download)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages))

 (define-public time
@@ -72,7 +72,7 @@  (define-public time
      "Time is a command that displays information about the resources that a
 program uses.  The display output of the program can be customized or saved
 to a file.")
-    (license gpl3+)))
+    (license license:gpl3+)))

 (define-public python-pytimeparse
   (package
@@ -92,7 +92,7 @@  (define-public python-pytimeparse
     (synopsis "Time expression parser")
     (description "This small Python module parses various kinds of time
 expressions.")
-    (license expat)))
+    (license license:expat)))

 (define-public python-pytzdata
   (package
@@ -115,7 +115,7 @@  (define-public python-pytzdata
     (synopsis "Timezone database for Python")
     (description
      "This library provides a timezone database for Python.")
-    (license expat)))
+    (license license:expat)))

 (define-public python2-tzdata
   (package-with-python2 python-pytzdata))
@@ -139,7 +139,7 @@  (define-public python-pytz
 allows accurate and cross platform timezone calculations using Python 2.4 or
 higher.  It also solves the issue of ambiguous times at the end of daylight
 saving time.  Almost all of the Olson timezones are supported.")
-    (license expat)))
+    (license license:expat)))

 (define-public python2-pytz
   (package-with-python2 python-pytz))
@@ -167,7 +167,7 @@  (define-public python-pendulum
 @{datetime} class, providing an alternative API.  As it inherits from the
 standard @code{datetime} all @code{datetime} instances can be replaced by
 Pendulum instances.")
-    (license expat)))
+    (license license:expat)))

 (define-public python-dateutil
   (package
@@ -208,7 +208,7 @@  (define-public python-dateutil
     ;; The license was changed from the three-clause BSD license to a dual
     ;; Apache 2.0/BSD-3 variant at 2017-12-01.  Some code is only available as
     ;; BSD-3 still; but all new code is dual licensed (the user can choose).
-    (license (list bsd-3 asl2.0))))
+    (license (list license:bsd-3 license:asl2.0))))

 (define-public python2-dateutil
   (package-with-python2 python-dateutil))
@@ -236,7 +236,7 @@  (define-public python-parsedatetime
     (synopsis "Parse human-readable date/time text")
     (description
      "Parse human-readable date/time text.")
-    (license asl2.0)))
+    (license license:asl2.0)))

 (define-public python2-parsedatetime
   (package-with-python2 python-parsedatetime))
@@ -267,7 +267,7 @@  (define-public python-ciso8601
     (description
      "The package ciso8601 converts ISO 8601 or RFC 3339 date time strings into
 Python datetime objects.")
-    (license expat)))
+    (license license:expat)))

 (define-public python-tzlocal
   (package
@@ -305,7 +305,7 @@  (define-public python-tzlocal
 This module attempts to fix a glaring hole in pytz, that there is no way to
 get the local timezone information, unless you know the zoneinfo name, and
 under several distributions that's hard or impossible to figure out.")
-    (license expat)))
+    (license license:expat)))

 (define-public python-isodate
   (package
@@ -326,7 +326,7 @@  (define-public python-isodate
     (description
      "Python-isodate is a python module for parsing and formatting
 ISO 8601 dates, time and duration.")
-    (license bsd-3)))
+    (license license:bsd-3)))

 (define-public python2-isodate
   (package-with-python2 python-isodate))
@@ -355,7 +355,7 @@  (define-public python-iso8601
     (description
      "This module parses the most common forms of ISO 8601 date strings (e.g.
 @code{2007-01-14T20:34:22+00:00}) into @code{datetime} objects.")
-    (license expat)))
+    (license license:expat)))

 (define-public python2-iso8601
   (package-with-python2 python-iso8601))
@@ -378,7 +378,7 @@  (define-public python-monotonic
     (description
      "This module provides a @code{monotonic()} function which returns the
 value (in fractional seconds) of a clock which never goes backwards.")
-    (license asl2.0)))
+    (license license:asl2.0)))

 (define-public python2-monotonic
   (package-with-python2 python-monotonic))
@@ -403,7 +403,7 @@  (define-public python-pyrfc3339
     (synopsis "Python timestamp library")
     (description "Python library for generating and parsing RFC 3339-compliant
 timestamps.")
-    (license expat)))
+    (license license:expat)))

 (define-public python2-pyrfc3339
   (package-with-python2 python-pyrfc3339))
@@ -445,7 +445,7 @@  (define-public python-arrow
      "Arrow is a Python library to creating, manipulating, formatting and
 converting dates, times, and timestamps.  It implements and updates the
 datetime type.")
-    (license asl2.0)))
+    (license license:asl2.0)))

 (define-public python-aniso8601
   (package
@@ -510,7 +510,7 @@  (define-public datefudge
      "Utility that fakes the system time by pre-loading a small library that
 modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
 calls.")
-    (license gpl2)))
+    (license license:gpl2)))

 (define-public countdown
   (package
@@ -537,4 +537,4 @@  (define-public countdown
      "Countdown provides a fancy text display while it counts down to zero
 from a starting point you provide.  The user can pause and resume the
 countdown from the text user interface.")
-    (license expat)))
+    (license license:expat)))