diff mbox series

[bug#51739,3/3] gnu: Add rdate.

Message ID kp9AWdEEXaZbjd9epDygdzA9aOR9qbdm407QfhvojIvz_n95Gs20MqKtFug3IQNbdFF70TtUsibU1nEY5EgXVH7tTX_fTmaVgZ4tKyfN_dQ=@protonmail.com
State Accepted
Headers show
Series [bug#51739,1/3] gnu: Add realmd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 10, 2021, 3:08 a.m. UTC
* gnu/packages/time.scm (rdate): New variable.

--
2.33.1

Comments

Leo Famulari Nov. 10, 2021, 10:29 p.m. UTC | #1
On Wed, Nov 10, 2021 at 03:08:17AM +0000, phodina via Guix-patches via wrote:
> * gnu/packages/time.scm (rdate): New variable.

Thanks for the patch!

> +(define-public rdate
> +  (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
> +        (revision "1"))
> +    (package
> +      (name "rdate")
> +      (version commit)

As described in the manual section Version Numbers [0], we should use the
git-version procedure to create the package's version. As the most
recent Git tag before the specified commit is 1.4, it would be like
this:

(version (git-version "1.4" revision commit))

> +      (synopsis "Get date and time based on RFC 868")
> +      (description "@code{rdate} connects to an RFC 868 time server over a TCP/IP
> +network, printing the returned time and/or setting the system clock.")
> +      (home-page "https://www.aelius.com/njh/rdate/")
> +      (license license:gpl2))))

The license header of 'src/rdate.c' says "version 2 of the License, or
(at your option) any later version.", so the license is gpl2+.

Can you send a revised patch?

[0] https://guix.gnu.org/manual/en/html_node/Version-Numbers.html
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index ce0f644194..581a40f5d3 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -36,6 +36,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

 (define-module (gnu packages time)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages golang)
@@ -465,11 +466,35 @@  (define-public python-aniso8601
     (synopsis "Python library for parsing ISO 8601 strings")
     (description
      "This package contains a library for parsing ISO 8601 datetime strings.")
-    (license bsd-3)))
+    (license license:bsd-3)))

 (define-public python2-aniso8601
   (package-with-python2 python-aniso8601))

+(define-public rdate
+  (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+        (revision "1"))
+    (package
+      (name "rdate")
+      (version commit)
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/njh/rdate")
+                      (commit version)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+      (build-system gnu-build-system)
+      (native-inputs `(("autoconf" ,autoconf)
+                       ("automake" ,automake)))
+      (synopsis "Get date and time based on RFC 868")
+      (description "@code{rdate} connects to an RFC 868 time server over a TCP/IP
+network, printing the returned time and/or setting the system clock.")
+      (home-page "https://www.aelius.com/njh/rdate/")
+      (license license:gpl2))))
+
 (define-public datefudge
   (package
     (name "datefudge")