diff mbox series

[bug#49619,v3,1/2] gnu: Add python-very-pretty-table.

Message ID 8635pxxpke.fsf@mgsn.dev
State New
Headers show
Series [bug#49619,v3,1/2] gnu: Add python-very-pretty-table. | expand

Commit Message

Sarah Morgensen Sept. 22, 2021, 3:21 a.m. UTC
Hi,

phodina <phodina@protonmail.com> writes:

> Hi Sarah!
>
> Are these fixes now compliant to upstream the patch?

It's pretty good.  I went ahead and made a few changes (attached below):
I tweaked the descriptions, I changed very-pretty-table to
veryprettytable so the python importer can find it in the future, I
changed pirate-get's propagated-inputs to inputs since it's an end-user
package, and I changed the license of pirate-get to AGPL-3.

* Package review checklist (WIP)
Lack of a check is not proof of noncompliance.

1. [X] Package builds (guix build package)
     [X] x86_64  [ ] aarch64  [ ] armhf     [ ] powerpc64le
     [ ] i686    [ ] i586     [ ] mips64le
2. [X] Build is reproducible (guix build --rounds=n package)
3. [X] Tests enabled (if available) or disabled with in-source comment
4. [X] No extraneous dependencies (guix size package)
5. [X] No unnecessary pre-built binaries/blobs
6. [X] Dependencies unvendored when available in Guix
7. [X] Cross-compile friendly (cc-for-target, patches with inputs)
8. [X] License matches source
9. [X] No problematic lints (guix lint package)
10. [X] Formatting follows guidelines
    - [X] Lines wrap at 80 characters
    - [X] Indentation passes etc/indent-code.el
    - [X] Two spaces used between sentences

For new packages:
1. [X] Source url is robust
   * mirror:// used with url-fetch when possible
   * No auto-generated archives from source repo (prefer cloning)
2. [X] Synopsis is short, descriptive, and meaningful to a wide audience
3. [X] Description is objective, takes 5-10 lines, uses full sentences,
   and provides the information users need to decide whether the
   software fits their needs.

I also gave it a spin, and it works fine as long as the SSL_CERT_DIR
environment variable is defined (I think that's beyond the scope of this
package). LGTM.

Thanks for your work!

--
Sarah

Comments

phodina Sept. 27, 2021, 10:41 p.m. UTC | #1
On Wednesday, September 22nd, 2021 at 5:21 AM, Sarah Morgensen <iskarian@mgsn.dev> wrote:

> Hi,
>
> phodina phodina@protonmail.com writes:
>
> > Hi Sarah!
> >
> > Are these fixes now compliant to upstream the patch?
>
> It's pretty good. I went ahead and made a few changes (attached below):
>
> I tweaked the descriptions, I changed very-pretty-table to
>
> veryprettytable so the python importer can find it in the future, I
>
> changed pirate-get's propagated-inputs to inputs since it's an end-user
>
> package, and I changed the license of pirate-get to AGPL-3.
>
> -   Package review checklist (WIP)
>
>     Lack of a check is not proof of noncompliance.
>
> 1.  [X] Package builds (guix build package)
>
>     [X] x86_64 [ ] aarch64 [ ] armhf [ ] powerpc64le
>
>     [ ] i686 [ ] i586 [ ] mips64le
> 2.  [X] Build is reproducible (guix build --rounds=n package)
> 3.  [X] Tests enabled (if available) or disabled with in-source comment
> 4.  [X] No extraneous dependencies (guix size package)
> 5.  [X] No unnecessary pre-built binaries/blobs
> 6.  [X] Dependencies unvendored when available in Guix
> 7.  [X] Cross-compile friendly (cc-for-target, patches with inputs)
> 8.  [X] License matches source
> 9.  [X] No problematic lints (guix lint package)
> 10.  [X] Formatting follows guidelines
>     -   [X] Lines wrap at 80 characters
>     -   [X] Indentation passes etc/indent-code.el
>     -   [X] Two spaces used between sentences
>
>         For new packages:
> 11.  [X] Source url is robust
>     -   mirror:// used with url-fetch when possible
>     -   No auto-generated archives from source repo (prefer cloning)
> 12.  [X] Synopsis is short, descriptive, and meaningful to a wide audience
> 13.  [X] Description is objective, takes 5-10 lines, uses full sentences,
>

Thanks for the list! I'll follow it next time I'll submit a package or propose a change :-)
>     and provides the information users need to decide whether the
>
>     software fits their needs.
>
>     I also gave it a spin, and it works fine as long as the SSL_CERT_DIR
>
>     environment variable is defined (I think that's beyond the scope of this
>

Well I also thought about the certificates but as you mentioned that's probably out of scope and it would be good to handle it by default in the build script so that we don't have to do it for the packages requiring network connectivity.
>     package). LGTM.
>
>     Thanks for your work!

You're welcome. Guix is the exact distribution I've been looking for and porting tools I use is a nice way to get familiar with the Guile programming language and the ideas behind Guix (and Nix :)
>
>     --
>
>     Sarah
diff mbox series

Patch

From 5e99c1f791c990dd76cd63a9ab2a5196656c5c6f Mon Sep 17 00:00:00 2001
Message-Id: <5e99c1f791c990dd76cd63a9ab2a5196656c5c6f.1632277047.git.iskarian@mgsn.dev>
In-Reply-To: <e468a5f5722a31ce9999ddba43a8de120521a938.1632277047.git.iskarian@mgsn.dev>
References: <e468a5f5722a31ce9999ddba43a8de120521a938.1632277047.git.iskarian@mgsn.dev>
From: phodina <phodina@protonmail.com>
Date: Sat, 18 Sep 2021 12:45:04 +0000
Subject: [PATCH v4 2/2] gnu: Add python-pirate-get.

* gnu/packages/python-xyz.scm (python-pirate-get): New variable.
---
 gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1f162d079..86962e35b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1820,6 +1820,34 @@  inserted directly, read from a CSV file, or imported using a Python DB-API
 database cursor such as @code{sqlite3}.")
     (license license:bsd-3)))
 
+(define-public python-pirate-get
+  (package
+    (name "python-pirate-get")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pirate-get" version))
+       (sha256
+        (base32
+         "07s5ss9dxccx1mip7pyga1fagywkqchxmzz55ng47ac9053ffxkq"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-pyperclip" ,python-pyperclip)
+       ("python-veryprettytable" ,python-veryprettytable)))
+    (home-page
+     "https://github.com/vikstrous/pirate-get")
+    (synopsis
+     "Command line interface for The Pirate Bay")
+    (description
+     "@code{pirate-get} is an unofficial command line interface for searching
+The Pirate Bay, inspired by @command{apt}.  Results can be saved as JSON,
+@code{.torrent} files, or magnet links, or they can be opened directly in
+@command{transmission-remote}.  @code{pirate-get} also supports searching
+mirrors or a local copy of The Pirate Bay's database.")
+    (license license:agpl3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))
-- 
2.33.0