diff mbox series

[bug#50724,3/3] gnu: Add python-zeep.

Message ID 6514049df6c3b4bfd534252eec1ecce93f66619f.1632251925.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#50724,1/3] gnu: Add python-charset-normalizer. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 21, 2021, 7:22 p.m. UTC
* gnu/packages/python-web.scm (python-zeep): New variable.
---
 gnu/packages/python-web.scm | 42 +++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Xinglu Chen Sept. 21, 2021, 8:16 p.m. UTC | #1
On Tue, Sep 21 2021, Hartmut Goebel wrote:

> * gnu/packages/python-web.scm (python-zeep): New variable.
> ---
>  gnu/packages/python-web.scm | 42 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 42 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 302e5d6459..10507240e1 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -6234,3 +6234,45 @@ communicate with Microsoft Azure Storage services.")
>  or tags from HTML snippets, extract base url from HTML snippets, translate entites
>  on HTML strings, among other things.")
>      (license license:bsd-3)))
> +
> +(define-public python-zeep
> +  (package
> +    (name "python-zeep")
> +    (version "4.1.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "zeep" version))
> +       (sha256
> +        (base32 "1ranr4hkjd2kbbhxa3is1qlgkankj3sml5gla6bqs0kbvpmg4rsq"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     `(("python-attrs" ,python-attrs)
> +       ("python-cached-property" ,python-cached-property)
> +       ("python-isodate" ,python-isodate)
> +       ("python-lxml" ,python-lxml)
> +       ("python-platformdirs" ,python-platformdirs)
> +       ("python-pytz" ,python-pytz)
> +       ("python-requests" ,python-requests)
> +       ("python-requests-file" ,python-requests-file)
> +       ("python-requests-toolbelt" ,python-requests-toolbelt)))
> +    (native-inputs
> +     `(("python-coverage" ,python-coverage)
> +       ;;("python-flake8" ,python-flake8)
> +       ;; ("python-flake8-blind-except" ,python-flake8-blind-except)
> +       ;; ("python-flake8-debugger" ,python-flake8-debugger)
> +       ;; ("python-flake8-imports" ,python-flake8-imports)
> +       ("python-freezegun" ,python-freezegun)
> +       ;;("python-isort" ,python-isort)

Why are some of these inputs commented out?

> +       ("python-mock" ,python-mock)
> +       ("python-pretend" ,python-pretend)
> +       ("python-pytest" ,python-pytest)
> +       ("python-pytest-asyncio" ,python-pytest-asyncio)
> +       ("python-pytest-cov" ,python-pytest-cov)
> +       ("python-pytest-httpx" ,python-pytest-httpx)

‘python-pytest-httpx’ doesn’t seem to exist; which commit are you basing
these patches off of?  My checkout is based off of commit
5966d48d1c9e48b7098845193469f5b5fe07d540.

This is why people should be using the ‘--base’ flag when invoking ‘git
format-patch’.  :-)

> +       ("python-requests-mock" ,python-requests-mock)))
> +    (home-page "http://docs.python-zeep.org")

Why not HTTPS?

> +    (synopsis "Fast and modern Python SOAP client")
> +    (description "This package provides a fast and modern Python SOAP client
> +based on lxml and requests.")

I would use @code{python-lxml} and @code{python-requests} to make it
clear that these are packages and not just regular words.
Hartmut Goebel Sept. 23, 2021, 5:09 p.m. UTC | #2
Hi Xinglu,
> ‘python-pytest-httpx’ doesn’t seem to exist; which commit are you basing

Ups, Sorry for wasting your time by submitting an incomplete patch. I 
withdrew the patch.

I cherry-picked this patch from another pile of patches, which contains 
python-pytest-httpx. Anyhow packaging python-pytest-httpx ended up in 
updating many other packages, updating which is to touchy for me.
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 302e5d6459..10507240e1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6234,3 +6234,45 @@  communicate with Microsoft Azure Storage services.")
 or tags from HTML snippets, extract base url from HTML snippets, translate entites
 on HTML strings, among other things.")
     (license license:bsd-3)))
+
+(define-public python-zeep
+  (package
+    (name "python-zeep")
+    (version "4.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "zeep" version))
+       (sha256
+        (base32 "1ranr4hkjd2kbbhxa3is1qlgkankj3sml5gla6bqs0kbvpmg4rsq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-attrs" ,python-attrs)
+       ("python-cached-property" ,python-cached-property)
+       ("python-isodate" ,python-isodate)
+       ("python-lxml" ,python-lxml)
+       ("python-platformdirs" ,python-platformdirs)
+       ("python-pytz" ,python-pytz)
+       ("python-requests" ,python-requests)
+       ("python-requests-file" ,python-requests-file)
+       ("python-requests-toolbelt" ,python-requests-toolbelt)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ;;("python-flake8" ,python-flake8)
+       ;; ("python-flake8-blind-except" ,python-flake8-blind-except)
+       ;; ("python-flake8-debugger" ,python-flake8-debugger)
+       ;; ("python-flake8-imports" ,python-flake8-imports)
+       ("python-freezegun" ,python-freezegun)
+       ;;("python-isort" ,python-isort)
+       ("python-mock" ,python-mock)
+       ("python-pretend" ,python-pretend)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-httpx" ,python-pytest-httpx)
+       ("python-requests-mock" ,python-requests-mock)))
+    (home-page "http://docs.python-zeep.org")
+    (synopsis "Fast and modern Python SOAP client")
+    (description "This package provides a fast and modern Python SOAP client
+based on lxml and requests.")
+    (license license:expat)))