diff mbox series

[bug#50724,2/3] gnu: Add python-platformdirs.

Message ID 3c719027baff05520288c3f0f0e97988a9565f7b.1632251925.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#50724,1/3] gnu: Add python-charset-normalizer. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Hartmut Goebel Sept. 21, 2021, 7:22 p.m. UTC
* gnu/packages/python-xyz.scm (python-platformdirs): New variable.
---
 gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Xinglu Chen Sept. 21, 2021, 8:12 p.m. UTC | #1
On Tue, Sep 21 2021, Hartmut Goebel wrote:

> * gnu/packages/python-xyz.scm (python-platformdirs): New variable.
> ---
>  gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 7239fa1584..908e9dbff6 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -26799,3 +26799,29 @@ services' API.  It includes a pre-defined set of classes for API resources
>  that initialize themselves dynamically from API responses which makes it
>  compatible with a wide range of versions of the Stripe API.")
>      (license license:expat)))
> +
> +(define-public python-platformdirs
> +  (package
> +    (name "python-platformdirs")
> +    (version "2.2.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "platformdirs" version))
> +       (sha256
> +        (base32 "07hq5qrp7pqj63iczg01wbf5ii6f0ncd0dq5mzkdhsslmg9slbb3"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     `(("python-appdirs" ,python-appdirs)
> +       ("python-pytest" ,python-pytest)
> +       ("python-pytest-cov" ,python-pytest-cov)
> +       ("python-pytest-mock" ,python-pytest-mock)))
> +    (home-page "https://github.com/platformdirs/platformdirs")
> +    (synopsis "Determine the appropriate platform-specific dirs, e.g. \"user
> +data dir\"")

The example is also mentioned in the description, so I would drop the
“e.g. ...” part.  Also, I would write “directories” instead of “dirs”,
just for the sake of clarity.

> +    (description "When writing applications, finding the right location to
> +store user data and configuration varies per platform.  Even for
> +single-platform apps, there may by plenty of nuances in figuring out the right
> +location.  This small Python module determines the appropriate
> +platform-specific directories, e.g. the \"user data dir\".")

Use ``'' instead of "", see the Texinfo manual on quote characters.

  <https://www.gnu.org/software/texinfo/manual/texinfo/texinfo.html#Inserting-Quote-Characters>
Hartmut Goebel Sept. 23, 2021, 5:11 p.m. UTC | #2
Hi Xinglu,

thanks for the fast review.

I adjusted python-platformdirs as you recommended and pushed both 
python-charset-normalizer and python-platformdirs as 
a24ae17e230d8d1f8b036c298e68fdcb08edff62

The python-zeep I withdrew.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7239fa1584..908e9dbff6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26799,3 +26799,29 @@  services' API.  It includes a pre-defined set of classes for API resources
 that initialize themselves dynamically from API responses which makes it
 compatible with a wide range of versions of the Stripe API.")
     (license license:expat)))
+
+(define-public python-platformdirs
+  (package
+    (name "python-platformdirs")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "platformdirs" version))
+       (sha256
+        (base32 "07hq5qrp7pqj63iczg01wbf5ii6f0ncd0dq5mzkdhsslmg9slbb3"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-appdirs" ,python-appdirs)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-pytest-mock" ,python-pytest-mock)))
+    (home-page "https://github.com/platformdirs/platformdirs")
+    (synopsis "Determine the appropriate platform-specific dirs, e.g. \"user
+data dir\"")
+    (description "When writing applications, finding the right location to
+store user data and configuration varies per platform.  Even for
+single-platform apps, there may by plenty of nuances in figuring out the right
+location.  This small Python module determines the appropriate
+platform-specific directories, e.g. the \"user data dir\".")
+    (license license:expat)))