diff mbox series

[bug#48325,3/4] gnu: openlibm: Update to 0.7.4.

Message ID 20210629132128.22249-4-jbv@pm.me
State Accepted
Headers show
Series DRAFT gnu: julia: Update to 1.6.1 | expand

Commit Message

Jean-Baptiste Volatier June 29, 2021, 1:23 p.m. UTC
* gnu/packages/maths.scm (openlibm): Update to 0.7.4.
---
 gnu/packages/maths.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--
2.32.0

Comments

M July 1, 2021, 8:22 a.m. UTC | #1
>      (arguments
>       `(#:make-flags
> -       (list (string-append "prefix=" (assoc-ref %outputs "out")))
> +       (list (string-append "prefix=" (assoc-ref %outputs "out")) "CC=gcc")

The cross-compiler TARGET-gcc is require when cross-compiling,
so you need ,(string-append "CC=" (cc-for-target)) instead of "CC=gcc"
here. "gcc" is always the native compiler.

You can test if cross-compilation seems to work with
  ./pre-inst-env guix build --target=aarch64-linux-gnu openlibm

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 42e85fee6e..cb624cd62a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3998,7 +3998,7 @@  access to BLIS implementations via traditional BLAS routine calls.")
 (define-public openlibm
   (package
     (name "openlibm")
-    (version "0.6.0")
+    (version "0.7.4")
     (source
      (origin
        (method git-fetch)
@@ -4007,11 +4007,11 @@  access to BLIS implementations via traditional BLAS routine calls.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "08wfchmmr5200fvmn1kwq9byc1fhsq46hn0y5k8scdl74771c7gh"))))
+        (base32 "1azms0lpxb7vxb3bln5lyz0wpwx6jnzbffkclclpq2v5aiw8d14i"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (list (string-append "prefix=" (assoc-ref %outputs "out")))
+       (list (string-append "prefix=" (assoc-ref %outputs "out")) "CC=gcc")
        #:phases
        ;; no configure script
        (modify-phases %standard-phases (delete 'configure))