diff mbox series

[bug#48325,1/4] gnu: Add utf8proc-2.6.1.

Message ID 20210629132128.22249-2-jbv@pm.me
State Accepted
Headers show
Series DRAFT gnu: julia: Update to 1.6.1 | expand

Commit Message

Jean-Baptiste Volatier June 29, 2021, 1:23 p.m. UTC
* gnu/packages/textutils.scm (utf8proc-2.6.1): New variable.

Co-Authored-By: zimoun <zimon.toutoune@gmail.com>.
---
 gnu/packages/textutils.scm | 41 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)

--
2.32.0

Comments

M July 1, 2021, 8:18 a.m. UTC | #1
Jean-Baptiste Volatier via Guix-patches via schreef op di 29-06-2021 om 13:23 [+0000]:
> * gnu/packages/textutils.scm (utf8proc-2.6.1): New variable.
> 
> Co-Authored-By: zimoun <zimon.toutoune@gmail.com>.
> ---
>  gnu/packages/textutils.scm | 41 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 41 insertions(+)
> 
> diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
> index ab34373705..dbd6dce283 100644
> --- a/gnu/packages/textutils.scm
> +++ b/gnu/packages/textutils.scm
> @@ -20,6 +20,7 @@
>  ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
>  ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
>  ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -63,6 +64,7 @@
>    #:use-module (gnu packages python-build)
>    #:use-module (gnu packages python-xyz)
>    #:use-module (gnu packages readline)
> +  #:use-module (gnu packages ruby)
>    #:use-module (gnu packages slang)
>    #:use-module (gnu packages web))
> 
> @@ -201,6 +203,45 @@ normalization, case-folding, and other operations for data in the UTF-8
>  encoding, supporting Unicode version 9.0.0.")
>      (license license:expat)))
> 
> +(define-public utf8proc-2.6.1
> +  (package
> +    (inherit utf8proc)
> +    (name "utf8proc")
> +    (version "2.6.1")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/JuliaStrings/utf8proc")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1zqc6airkzkssbjxanx5v8blfk90180gc9id0dx8ncs54f1ib8w7"))))
> +    (arguments
> +     (substitute-keyword-arguments (package-arguments utf8proc)
> +       ((#:phases phases)
> +        `(modify-phases ,phases
> +           (replace 'check-data
> +             (lambda* (#:key inputs #:allow-other-keys)
> +               (for-each (lambda (i)
> +                           (copy-file (assoc-ref inputs i)
> +                                      (string-append "data/" i)))

'DerivedCoreProperties.txt" is in 'native-inputs',
so you need to do (assoc-ref (or native-inputs inputs) (string-append "data/" i))
to make sure it will be found when cross-compiling.

(When compiling natively, 'inputs' is merged into 'native-inputs')

> +                         '("NormalizationTest.txt" "GraphemeBreakTest.txt"
> +                           "DerivedCoreProperties.txt"))))))))
> +    (native-inputs
> +     (append
> +      (package-native-inputs utf8proc)


> +      (let ((UNICODE_VERSION "13.0.0"))
> +        `(("DerivedCoreProperties.txt"

Alternatively, you could move "DerivedCoreProperties.txt"
to 'inputs'. It isn't something that is compiled, so it
doesn't really matter if it is in 'inputs' or 'native-inputs',
except for ‘style’ I
suppose.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index ab34373705..dbd6dce283 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -63,6 +64,7 @@ 
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages readline)
+  #:use-module (gnu packages ruby)
   #:use-module (gnu packages slang)
   #:use-module (gnu packages web))

@@ -201,6 +203,45 @@  normalization, case-folding, and other operations for data in the UTF-8
 encoding, supporting Unicode version 9.0.0.")
     (license license:expat)))

+(define-public utf8proc-2.6.1
+  (package
+    (inherit utf8proc)
+    (name "utf8proc")
+    (version "2.6.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaStrings/utf8proc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zqc6airkzkssbjxanx5v8blfk90180gc9id0dx8ncs54f1ib8w7"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments utf8proc)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (replace 'check-data
+             (lambda* (#:key inputs #:allow-other-keys)
+               (for-each (lambda (i)
+                           (copy-file (assoc-ref inputs i)
+                                      (string-append "data/" i)))
+                         '("NormalizationTest.txt" "GraphemeBreakTest.txt"
+                           "DerivedCoreProperties.txt"))))))))
+    (native-inputs
+     (append
+      (package-native-inputs utf8proc)
+      (let ((UNICODE_VERSION "13.0.0"))
+        `(("DerivedCoreProperties.txt"
+           ,(origin
+              (method url-fetch)
+              (uri (string-append "https://www.unicode.org/Public/"
+                                  UNICODE_VERSION "/ucd/DerivedCoreProperties.txt"))
+              (sha256
+               (base32 "0j12x112cd8fpgazkc8izxnhhpia44p1m36ff8yapslxndcmzm55"))))
+          ;; For tests
+          ("ruby" ,ruby)))))))
+
 (define-public libconfuse
   (package
     (name "libconfuse")