diff mbox series

[bug#48980,2/2] gnu: icedove: Add WebAuthn support.

Message ID 20210612211931.11736-2-brice@waegenei.re
State Accepted
Headers show
Series icecat, icedove: Add U2F and WebAuthn support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brice Waegeneire June 12, 2021, 9:19 p.m. UTC
* gnu/packages/gnuzilla.scm (icedove)[inputs]: Add eudev.
[phases]: Add eudev to the wrapper.
---
 gnu/packages/gnuzilla.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Jonathan Brielmaier June 12, 2021, 10:09 p.m. UTC | #1
Hi Brice,

does Webauthn have any use case in Thunderbird? do you use it?

Am 12.06.21 um 23:19 schrieb Brice Waegeneire:
> * gnu/packages/gnuzilla.scm (icedove)[inputs]: Add eudev.
> [phases]: Add eudev to the wrapper.
Brice Waegeneire June 13, 2021, 7:51 a.m. UTC | #2
Hello Jonathan,

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

> does Webauthn have any use case in Thunderbird? do you use it?

I don't need U2F support in Icecdove. Before working on this patch I too
didn't knew Icedove was missing U2F support.  But glanccing at nixpkgs
repo I have found a closed bug¹ about that; there you can see someone
needed two factor authorization to login into its account.

¹ https://github.com/NixOS/nixpkgs/issues/87642

Cheers,
- Brice
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 6255d56f16..a6f0e61b12 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1541,10 +1541,12 @@  standards of the IceCat project.")
                     (gtk (assoc-ref inputs "gtk+"))
                     (gtk-share (string-append gtk "/share"))
                     (pulseaudio (assoc-ref inputs "pulseaudio"))
-                    (pulseaudio-lib (string-append pulseaudio "/lib")))
+                    (pulseaudio-lib (string-append pulseaudio "/lib"))
+                    (eudev (assoc-ref inputs "eudev"))
+                    (eudev-lib (string-append eudev "/lib")))
                (wrap-program (car (find-files lib "^icedove$"))
                  `("XDG_DATA_DIRS" prefix (,gtk-share))
-                 `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib)))
+                 `("LD_LIBRARY_PATH" prefix (,pulseaudio-lib ,eudev-lib)))
                #t))))))
     (inputs
      `(("bzip2" ,bzip2)
@@ -1580,6 +1582,7 @@  standards of the IceCat project.")
        ("pulseaudio" ,pulseaudio)
        ("sqlite" ,sqlite)
        ("startup-notification" ,startup-notification)
+       ("eudev" ,eudev)
        ("unzip" ,unzip)
        ("zip" ,zip)
        ("zlib" ,zlib)))