mbox series

[bug#48980,0/2] icecat, icedove: Add U2F and WebAuthn support

Message ID 20210612211630.10339-1-brice@waegenei.re
Headers show
Series icecat, icedove: Add U2F and WebAuthn support | expand

Message

Brice Waegeneire June 12, 2021, 9:16 p.m. UTC
This patch set closes https://issues.guix.gnu.org/45613 and
https://issues.guix.gnu.org/38341.

Brice Waegeneire (2):
  gnu: icecat: Add WebAuthn support.
  gnu: icedove: Add WebAuthn support.

 gnu/packages/gnuzilla.scm | 24 +++++++++++++++---------
 1 file changed, 15 insertions(+), 9 deletions(-)

Comments

Jonathan Brielmaier June 23, 2021, 9:09 p.m. UTC | #1
I pushed the icedove patch as a807d849219c34d45310634ef0cfc94ad9b7025a,
for the icecat one I would wait on Marks opinion...
Brice Waegeneire July 3, 2021, 3:55 p.m. UTC | #2
Hello Mark,

Could you take a look at this patch adding U2F support to icecat ?

Jonathan Brielmaier <jonathan.brielmaier@web.de> writes:

> I pushed the icedove patch as a807d849219c34d45310634ef0cfc94ad9b7025a,
> for the icecat one I would wait on Marks opinion...

Cheers,
- Brice
Mark H Weaver July 3, 2021, 5:18 p.m. UTC | #3
Hi Brice,

Brice Waegeneire <brice@waegenei.re> writes:
> Could you take a look at this patch adding U2F support to icecat ?

Thanks for this, but I see a problem.  The new input has key "eudev":

> @@ -910,6 +911,7 @@ from forcing GEXP-PROMISE."
>         ;; UNBUNDLE-ME! ("nss" ,nss)
>         ("shared-mime-info" ,shared-mime-info)
>         ;; UNBUNDLE-ME! ("sqlite" ,sqlite)
> +       ("eudev" ,eudev)
>         ("unzip" ,unzip)
>         ("zip" ,zip)
>         ;; UNBUNDLE-ME! ("zlib" ,zlib)

but the code added to the 'wrap-program' phase looks for key "udev":

> +                    (ld-libs (map (lambda (lib)
> +                                    (string-append (assoc-ref inputs lib)
> +                                                   "/lib"))
> +                              '("libxscrnsaver"
> +                                "mesa"
> +                                "mit-krb5"
> +                                "udev"
> +                                "pulseaudio"))))

I don't see how this can work.  Did you test it?

     Regards,
       Mark