diff mbox series

[bug#47643,staging,03/10] gnu: gst-plugins-base: Add missing inputs to enable more features.

Message ID 20210409183900.24175-4-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Update GStreamer to 1.18.4 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler April 9, 2021, 6:38 p.m. UTC
From: Raghav Gururajan <rg@raghavgururajan.name>

* gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Add gdk-pixbuf+svg,
glu, graphene, gtk+, iso-codes, libgudev, libjpeg-turbo, libvisual,
libxshmfence, mesa, sdl and wayland.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/gstreamer.scm | 27 ++++++++++++++++++++++-----
 1 file changed, 22 insertions(+), 5 deletions(-)

Comments

宋文武 April 10, 2021, 11 a.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> From: Raghav Gururajan <rg@raghavgururajan.name>
>
> * gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Add gdk-pixbuf+svg,
> glu, graphene, gtk+, iso-codes, libgudev, libjpeg-turbo, libvisual,
> libxshmfence, mesa, sdl and wayland.

Oh, I missed this one, and had sent a 'gst-plugins-base: Enable more
features' patch, which missing the opus 32bit skip part, I found that
was enabled by commit ea73e829d7d, so I think it should fine.

Also we can remove gdk-pixbuf, gtk+ and sdl, as they are only for
examples.  And libxshmfence is not needed, since I didn't find it
referenced in the source..

What do you think?
Raghav Gururajan April 10, 2021, 12:09 p.m. UTC | #2
On 2021-04-10 7:00 a.m., 宋文武 wrote:
> Leo Prikler <leo.prikler@student.tugraz.at> writes:
> 
>> From: Raghav Gururajan <rg@raghavgururajan.name>
>>
>> * gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Add gdk-pixbuf+svg,
>> glu, graphene, gtk+, iso-codes, libgudev, libjpeg-turbo, libvisual,
>> libxshmfence, mesa, sdl and wayland.
> 
> Oh, I missed this one, and had sent a 'gst-plugins-base: Enable more
> features' patch, which missing the opus 32bit skip part, I found that
> was enabled by commit ea73e829d7d, so I think it should fine.
> 
> Also we can remove gdk-pixbuf, gtk+ and sdl, as they are only for
> examples.  And libxshmfence is not needed, since I didn't find it
> referenced in the source..

I suspect gdk-pixpuf be used by any of the plugins/codecs during 
runtime. Removing other two are OK.

Regards,
RG.
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 5764b6d149..b2ad52592f 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,17 +559,34 @@  This package provides the core library and elements.")
              '()
              `(("orc" ,orc)))))         ;required by gstreamer-audio-1.0.pc
     (inputs
-     `(("cdparanoia" ,cdparanoia)
-       ("pango" ,pango)
+     `(("alsa-lib" ,alsa-lib)
+       ("cdparanoia" ,cdparanoia)
+       ("gdk-pixbuf" ,gdk-pixbuf+svg)
+       ("glu" ,glu)
+       ("graphene" ,graphene)
+       ("gtk+" ,gtk+)
+       ("iso-codes" ,iso-codes)
+       ("libgudev" ,libgudev)
+       ("libjpeg" ,libjpeg-turbo)
        ("libogg" ,libogg)
        ("libtheora" ,libtheora)
+       ("libvisual" ,libvisual)
        ("libvorbis" ,libvorbis)
        ("libx11" ,libx11)
-       ("zlib" ,zlib)
        ("libXext" ,libxext)
+       ("libxext" ,libxext)
+       ("libxshm" ,libxshmfence)
        ("libxv" ,libxv)
-       ("alsa-lib" ,alsa-lib)
-       ("opus" ,opus)))
+       ("mesa" ,mesa)
+       ;; XXX Don't build with opus on 32-bit systems:
+       ;; <https://bugs.gnu.org/32360>
+       ,@(if (target-64bit?)
+             `(("opus" ,opus))
+             '())
+       ("sdl" ,sdl)
+       ("wayland" ,wayland)
+       ("pango" ,pango)
+       ("zlib" ,zlib)))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("glib:bin" ,glib "bin")