diff mbox series

[bug#47643,staging,07/10] gnu: gst-plugins-bad: Update to 1.18.4.

Message ID 20210409183900.24175-8-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Update GStreamer to 1.18.4 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler April 9, 2021, 6:38 p.m. UTC
From: Raghav Gururajan <rg@raghavgururajan.name>

* gnu/packages/gstreamer.scm (gst-plugins-bad)[version]: Update to 1.18.4.
[arguments](glib-or-gtk): New argument.
[phases](pre-check): New phase.
[propagated-inputs]: Add gstreamer.
[native-inputs]: Add gettext-minimal, gsettings-desktop-schemas, perl and
xorg-server-for-tests. Replace python with python-wrapper.

Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
---
 gnu/packages/gstreamer.scm | 32 +++++++++++++++++++++++++-------
 1 file changed, 25 insertions(+), 7 deletions(-)

Comments

M April 9, 2021, 7:33 p.m. UTC | #1
On Fri, 2021-04-09 at 20:38 +0200, Leo Prikler wrote:
> From: Raghav Gururajan <rg@raghavgururajan.name>
> 
> * gnu/packages/gstreamer.scm (gst-plugins-bad)[version]: Update to 1.18.4.
> [arguments](glib-or-gtk): New argument.
> [phases](pre-check): New phase.
> [propagated-inputs]: Add gstreamer.
> [native-inputs]: Add gettext-minimal, gsettings-desktop-schemas, perl and
> xorg-server-for-tests. Replace python with python-wrapper.
> 
> Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
> ---
>  gnu/packages/gstreamer.scm | 32 +++++++++++++++++++++++++-------
>  1 file changed, 25 insertions(+), 7 deletions(-)
> 
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index 38b4fdbe63..cc739bd904 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -718,17 +718,18 @@ model to base your own plug-in on, here it is.")
>  (define-public gst-plugins-bad
>    (package
>      (name "gst-plugins-bad")
> -    (version "1.18.2")
> +    (version "1.18.4")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "https://gstreamer.freedesktop.org/src/"
>                                    name "/" name "-" version ".tar.xz"))
>                (sha256
>                 (base32
> -                "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))))
> +                "0py8k4pbalm9mxkpjbjxis0gp7g74wg5g4yax5q8rccmany0ds3l"))))
>      (build-system meson-build-system)
>      (arguments
> -     `(#:phases
> +     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
> +       #:phases
>         (modify-phases %standard-phases
>           ,@%common-gstreamer-phases
>           ,@(if (string-prefix? "arm" (or (%current-target-system)
> @@ -761,15 +762,32 @@ model to base your own plug-in on, here it is.")
>                   ((".*elements/curlhttpsrc\\.c.*") "")
>                   ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412
>                   ((".*elements/dtls\\.c.*") ""))
> -               #t))))))
> +               #t)))

Phases do not need to return #t anymore.  IIUC, the warning you
get when phases return something else has been removed on core-updates.

> +         (add-before 'check 'pre-check
> +           (lambda _
> +             ;; Tests require a running X server.
> +             (system "Xvfb :1 +extension GLX &")
> +             (setenv "DISPLAY" ":1")
> +             ;; Tests write to $HOME.
> +             (setenv "HOME" (getcwd))
> +             ;; Tests look for $XDG_RUNTIME_DIR.
> +             (setenv "XDG_RUNTIME_DIR" (getcwd))
> +             ;; For missing '/etc/machine-id'.
> +             (setenv "DBUS_FATAL_WARNINGS" "0")
> +             #t)))))

Likewise.  Likewise for the other patches.  I don't see any other problems
at the moment (I didn't test though).

Greetings,
Maxime.
Leo Prikler April 9, 2021, 7:53 p.m. UTC | #2
Am Freitag, den 09.04.2021, 21:33 +0200 schrieb Maxime Devos:
> On Fri, 2021-04-09 at 20:38 +0200, Leo Prikler wrote:
> > From: Raghav Gururajan <rg@raghavgururajan.name>
> > 
> > * gnu/packages/gstreamer.scm (gst-plugins-bad)[version]: Update to
> > 1.18.4.
> > [arguments](glib-or-gtk): New argument.
> > [phases](pre-check): New phase.
> > [propagated-inputs]: Add gstreamer.
> > [native-inputs]: Add gettext-minimal, gsettings-desktop-schemas,
> > perl and
> > xorg-server-for-tests. Replace python with python-wrapper.
> > 
> > Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
> > ---
> >  gnu/packages/gstreamer.scm | 32 +++++++++++++++++++++++++-------
> >  1 file changed, 25 insertions(+), 7 deletions(-)
> > 
> > diff --git a/gnu/packages/gstreamer.scm
> > b/gnu/packages/gstreamer.scm
> > index 38b4fdbe63..cc739bd904 100644
> > --- a/gnu/packages/gstreamer.scm
> > +++ b/gnu/packages/gstreamer.scm
> > @@ -718,17 +718,18 @@ model to base your own plug-in on, here it
> > is.")
> >  (define-public gst-plugins-bad
> >    (package
> >      (name "gst-plugins-bad")
> > -    (version "1.18.2")
> > +    (version "1.18.4")
> >      (source (origin
> >                (method url-fetch)
> >                (uri (string-append "
> > https://gstreamer.freedesktop.org/src/"
> >                                    name "/" name "-" version
> > ".tar.xz"))
> >                (sha256
> >                 (base32
> > -                "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5
> > mca"))))
> > +                "0py8k4pbalm9mxkpjbjxis0gp7g74wg5g4yax5q8rccmany0d
> > s3l"))))
> >      (build-system meson-build-system)
> >      (arguments
> > -     `(#:phases
> > +     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile
> > schemas
> > +       #:phases
> >         (modify-phases %standard-phases
> >           ,@%common-gstreamer-phases
> >           ,@(if (string-prefix? "arm" (or (%current-target-system)
> > @@ -761,15 +762,32 @@ model to base your own plug-in on, here it
> > is.")
> >                   ((".*elements/curlhttpsrc\\.c.*") "")
> >                   ;; 
> > https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412
> >                   ((".*elements/dtls\\.c.*") ""))
> > -               #t))))))
> > +               #t)))
> 
> Phases do not need to return #t anymore.  IIUC, the warning you
> get when phases return something else has been removed on core-
> updates.
True, but since this a patch for staging, I think there remains a time
window between this being merged and core-updates being merged, in
which the warning would still be printed.  Plus, even post core-updates 
merge, ending in #t is not an "error", it's simply no longer needed.

> > +         (add-before 'check 'pre-check
> > +           (lambda _
> > +             ;; Tests require a running X server.
> > +             (system "Xvfb :1 +extension GLX &")
> > +             (setenv "DISPLAY" ":1")
> > +             ;; Tests write to $HOME.
> > +             (setenv "HOME" (getcwd))
> > +             ;; Tests look for $XDG_RUNTIME_DIR.
> > +             (setenv "XDG_RUNTIME_DIR" (getcwd))
> > +             ;; For missing '/etc/machine-id'.
> > +             (setenv "DBUS_FATAL_WARNINGS" "0")
> > +             #t)))))
> 
> Likewise.  Likewise for the other patches.  I don't see any other
> problems
> at the moment (I didn't test though).
One note w.r.t. testing:  Gstreamer keeps a registry in XDG_CACHE_HOME,
that will still refer to old paths and might potentially cause issues. 
That being said, I still haven't tested ^^"

Regards,
Leo
M April 10, 2021, 10:13 a.m. UTC | #3
On Fri, 2021-04-09 at 21:53 +0200, Leo Prikler wrote:
> Am Freitag, den 09.04.2021, 21:33 +0200 schrieb Maxime Devos:
> > [...]
> > Phases do not need to return #t anymore.  IIUC, the warning you
> > get when phases return something else has been removed on core-
> > updates.
> True, but since this a patch for staging, I think there remains a time
> window between this being merged and core-updates being merged, in
> which the warning would still be printed.  Plus, even post core-updates 
> merge, ending in #t is not an "error", it's simply no longer needed.
Fair enough.  I've seen someone else (I don't recall the names anymore)
on the mailing list (other patches) requesting to remove #t though.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 38b4fdbe63..cc739bd904 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -718,17 +718,18 @@  model to base your own plug-in on, here it is.")
 (define-public gst-plugins-bad
   (package
     (name "gst-plugins-bad")
-    (version "1.18.2")
+    (version "1.18.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://gstreamer.freedesktop.org/src/"
                                   name "/" name "-" version ".tar.xz"))
               (sha256
                (base32
-                "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))))
+                "0py8k4pbalm9mxkpjbjxis0gp7g74wg5g4yax5q8rccmany0ds3l"))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
+     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
+       #:phases
        (modify-phases %standard-phases
          ,@%common-gstreamer-phases
          ,@(if (string-prefix? "arm" (or (%current-target-system)
@@ -761,15 +762,32 @@  model to base your own plug-in on, here it is.")
                  ((".*elements/curlhttpsrc\\.c.*") "")
                  ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412
                  ((".*elements/dtls\\.c.*") ""))
-               #t))))))
+               #t)))
+         (add-before 'check 'pre-check
+           (lambda _
+             ;; Tests require a running X server.
+             (system "Xvfb :1 +extension GLX &")
+             (setenv "DISPLAY" ":1")
+             ;; Tests write to $HOME.
+             (setenv "HOME" (getcwd))
+             ;; Tests look for $XDG_RUNTIME_DIR.
+             (setenv "XDG_RUNTIME_DIR" (getcwd))
+             ;; For missing '/etc/machine-id'.
+             (setenv "DBUS_FATAL_WARNINGS" "0")
+             #t)))))
     (propagated-inputs
-     `(("gst-plugins-base" ,gst-plugins-base)))
+     `(("gstreamer" ,gstreamer)
+       ("gst-plugins-base" ,gst-plugins-base)))
     (native-inputs
-     `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+     `(("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")         ; for glib-mkenums, etc.
        ("gobject-introspection" ,gobject-introspection)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gst-plugins-good" ,gst-plugins-good) ;for tests
+       ("perl" ,perl)
        ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+       ("python" ,python-wrapper)
+       ("xorg-server" ,xorg-server-for-tests)))
     (inputs
      ;; XXX: The following dependencies are missing:
      ;;  vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,