diff mbox series

[bug#41293] Add Pantheon desktop environment

Message ID 87tv0h0x0k.fsf@protonmail.com
State New
Headers show
Series [bug#41293] Add Pantheon desktop environment | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Deslauriers, Douglas via Guix-patches" via May 15, 2020, 8:21 p.m. UTC
This first patch adds the Granite library in gnu/packages/pantheon.scm.
It begins a patch series (to follow, 6 patches in total) that contains
some core pieces of the Pantheon desktop environment and a few
applications, laying the groundwork for further Pantheon packaging.

Comments

Danny Milosavljevic May 19, 2020, 9:49 a.m. UTC | #1
Hi,

thanks for the patch!

Added this one patch to guix master as commit 9f59a9b4bc93b3ef6cd3bd1c9eed04c30ba2d2d4
after removing gtk-update-icon-cache reference.
Ryan Prior May 19, 2020, 5:36 p.m. UTC | #2
Sorry about the all-native-inputs appstream package, I stopped paying
attention to it at some point. Here's a new appstream patch that bumps the
version and uses actual inputs.

Ryan

Ryan Prior (1):
  gnu: Add appstream.

 gnu/packages/freedesktop.scm | 59 ++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
Ryan Prior June 2, 2020, 1:27 a.m. UTC | #3
Here are updated patches for Sideload, Appstream, and Pantheon Terminal.

The sideload package is updated to the latest release. (1.1.1)

Sideload & pantheon-terminal packages are modified to disable compiling
schemas and updating desktop database as part of the install process.

These should all apply cleanly on master now. Let me know if there's still
further concerns!

Ryan Prior (3):
  gnu: Add sideload.
  gnu: Add appstream.
  gnu: Add pantheon-terminal.

 gnu/packages/freedesktop.scm |  59 +++++++++++++++++++
 gnu/packages/pantheon.scm    | 110 +++++++++++++++++++++++++++++++++++
 2 files changed, 169 insertions(+)
Deslauriers, Douglas via Guix-patches" via June 18, 2020, 10:30 p.m. UTC | #4
Hey folks, just bumping this patch set!

Ryan
Ludovic Courtès Sept. 9, 2020, 8:57 p.m. UTC | #5
Hello Ryan,

Did you have a chance to look at the comments Marius made back in June?

  https://issues.guix.gnu.org/41293

It would be nice to unlock this patch series!  :-)

Ludo’.
diff mbox series

Patch

From fdfe0c404b41b543eff94bcf96056ffb2f26c6f5 Mon Sep 17 00:00:00 2001
From: Ryan Prior <rprior@protonmail.com>
Date: Fri, 15 May 2020 14:24:23 -0500
Subject: [PATCH 1/6] gnu: Add granite.

* gnu/packages: (pantheon.scm): New File.
* gnu/local.mk: Add gnu/packages/pantheon.scm.
* gnu/packages/pantheon.scm (granite): New Variable.
---
 gnu/local.mk              |  1 +
 gnu/packages/pantheon.scm | 61 +++++++++++++++++++++++++++++++++++++++
 2 files changed, 62 insertions(+)
 create mode 100644 gnu/packages/pantheon.scm

diff --git a/gnu/local.mk b/gnu/local.mk
index ab2bac9bc5..5758df27be 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -403,6 +403,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/orpheus.scm			\
   %D%/packages/ots.scm				\
   %D%/packages/package-management.scm		\
+  %D%/packages/pantheon.scm			\
   %D%/packages/parallel.scm			\
   %D%/packages/password-utils.scm		\
   %D%/packages/patchutils.scm			\
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
new file mode 100644
index 0000000000..834ea74f37
--- /dev/null
+++ b/gnu/packages/pantheon.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages pantheon)
+  #:use-module (gnu packages gettext)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages)
+  #:use-module (guix build-system meson)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) :prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix utils))
+
+(define-public granite
+  (package
+    (name "granite")
+    (version "5.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/elementary/granite.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0acicv3f9gksb352v88lwap8ailjsxdrfknl2xql7blasbjzl2q0"))))
+    (build-system meson-build-system)
+    (inputs
+     `(("gtk" ,gtk+)
+       ("gtk+-bin" ,gtk+ "bin"))) ; for gtk-update-icon-cache
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("glib" ,glib)
+       ("gobject-introspection" ,gobject-introspection)
+       ("libgee" ,libgee)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
+    (home-page "https://github.com/elementary/granite")
+    (synopsis "Library that extends GTK with common widgets and utilities")
+    (description "Granite is a companion library for GTK+ and GLib.  Among other
+things, it provides complex widgets and convenience functions designed for use
+in apps built for the Pantheon desktop.")
+    (license license:lgpl3+)))
-- 
2.17.1