[bug#34692] gnu: add r-statcheck.

Message ID 20190301080758.5548-6-anothersms@gmail.com
State Accepted
Headers show
Series [bug#34692] gnu: add r-statcheck. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Nicolò Balzarotti March 1, 2019, 8:07 a.m. UTC
---
 gnu/packages/cran.scm | 38 +++++++++++++++++++++++++++++++-------
 1 file changed, 31 insertions(+), 7 deletions(-)

Comments

Ricardo Wurmus March 7, 2019, 7:43 p.m. UTC | #1
Hi Nicolò,

thanks for your patches.

Unfortunately, this patch includes unrelated changes (to
r-statnet-common) and does not have a proper commit summary.  The
changes adding r-statcheck lack a proper description (you should use
full sentences).

Would you like to send another patch addressing these issues?

Please also send related patches to the same bug number.  You can do
this by sending a cover letter to guix-patches@gnu.org, wait for the
acknowledgement, and then send the patches to the address mentioned in
the acknowledgement email.  This makes it easier for us to see in what
order related patches need to be applied.

Thanks!

--
Ricardo
Ludovic Courtès March 23, 2019, 8:58 p.m. UTC | #2
Hi Nicolò,

Ricardo Wurmus <rekado@elephly.net> skribis:

> Unfortunately, this patch includes unrelated changes (to
> r-statnet-common) and does not have a proper commit summary.  The
> changes adding r-statcheck lack a proper description (you should use
> full sentences).
>
> Would you like to send another patch addressing these issues?

Did you have a chance to look into that, Nicolò?

Thanks in advance!

Ludo’.
Nicolò Balzarotti March 23, 2019, 9:18 p.m. UTC | #3
Hi, sorry for the delay!
I'll try to have a look tomorrow :)

Nicolò

Il giorno sabato 23 marzo 2019, Ludovic Courtès <ludo@gnu.org> ha scritto:
> Hi Nicolò,
>
> Ricardo Wurmus <rekado@elephly.net> skribis:
>
>> Unfortunately, this patch includes unrelated changes (to
>> r-statnet-common) and does not have a proper commit summary.  The
>> changes adding r-statcheck lack a proper description (you should use
>> full sentences).
>>
>> Would you like to send another patch addressing these issues?
>
> Did you have a chance to look into that, Nicolò?
>
> Thanks in advance!
>
> Ludo’.
>

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 54031fa87a..111152d2d0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3736,19 +3736,43 @@  published results; and a routine for graphical display.")
 supports arbitrary vertex/edge/graph attributes.")
     (license license:gpl2+)))
 
+(define-public r-statcheck
+  (package
+    (name "r-statcheck")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "statcheck" version))
+       (sha256
+        (base32
+         "0ivybdcrymlsfv6pg6p5bv70qdvgxf2vgp0kf4r0pf2fcvav1mcp"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-plyr" ,r-plyr)
+       ("r-rmarkdown" ,r-rmarkdown)))
+    (home-page
+     "https://cran.r-project.org/web/packages/statcheck")
+    (synopsis
+     "Extract Statistics from Articles and Recompute p Values")
+    (description
+     "Extract statistics from articles and recompute p values.")
+    (license license:gpl2)))
+
 (define-public r-statnet-common
   (package
     (name "r-statnet-common")
     (version "4.2.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (cran-uri "statnet.common" version))
-        (sha256
-          (base32
-            "0q942g6kqmqxfss1cxb3yg8y5r1k1h5cyy99s1cfisrn6hqc6xhi"))))
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "statnet.common" version))
+       (sha256
+        (base32
+         "0q942g6kqmqxfss1cxb3yg8y5r1k1h5cyy99s1cfisrn6hqc6xhi"))))
     (properties
-      `((upstream-name . "statnet.common")))
+     `((upstream-name . "statnet.common")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-coda" ,r-coda)))