diff mbox series

[bug#57675,v4,03/10] gnu: telegram-desktop: Change API ID.

Message ID y76a66vrizk.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: telegram-desktop: Update to 4.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 19, 2022, 6:11 a.m. UTC
[#:configure-flags]: Use API ID from Telegram's official Snap builds.
---
 gnu/packages/telegram.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index cd25897634..cfa0d1c673 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -308,12 +308,10 @@  (define-public telegram-desktop
         (ice-9 match))
        #:configure-flags
        (list
-        ;; Client applications must provide their own API-ID and API-HASH,
+        ;; https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
         ;; see also <https://core.telegram.org/api/obtaining_api_id>.
-        ;; In case, that the credentials below fail to work, contact
-        ;;   Raghav Gururajan <rg@raghavgururajan.name>
-        "-DTDESKTOP_API_ID=2791056"
-        "-DTDESKTOP_API_HASH=582d6d0b44f7a2de949e99271fd8b3f2"
+        "-DTDESKTOP_API_ID=611335"
+        "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
         ;; Disable WebkitGTK support as it fails to link
         "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
         ;; Use bundled fonts as fallback.