diff mbox series

[bug#57675,v4,05/10] gnu: telegram-desktop: Use gexp.

Message ID y767d1zrixz.wl-hako@ultrarare.space
State Accepted
Headers show
Series gnu: telegram-desktop: Update to 4.2.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain Sept. 19, 2022, 6:12 a.m. UTC
* gnu/packages/telegram.scm (cmake-helpers-for-telegram-desktop,
codegen-for-telegram-desktop,lib-base-for-telegram-desktop,
lib-crl-for-telegram-desktop,lib-lottie-for-telegram-desktop,
lib-qr-for-telegram-desktop,lib-rlottie-for-telegram-desktop,
lib-rpl-for-telegram-desktop,lib-spellcheck-for-telegram-desktop,
lib-storage-for-telegram-desktop,lib-tl-for-telegram-desktop,
lib-ui-for-telegram-desktop,lib-waylandshells-for-telegram-desktop,
lib-webrtc-for-telegram-desktop,lib-webview-for-telegram-desktop,
tgcalls-for-telegram-desktop): New variables.
(telegram-desktop)[#:phases]: Copy sources with gexp.
[native-inputs,inputs]: Remove sources in flavor of variables.
---
 gnu/packages/telegram.scm | 515 +++++++++++++++++---------------------
 1 file changed, 229 insertions(+), 286 deletions(-)

--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index e6766d84eb..f56cbaf23a 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -99,6 +99,134 @@  (define libyuv-for-telegram-desktop
    #:hash "01knnk4h247rq536097n9n3s3brxlbby3nv3ppdgsqfda3k159ll"
    #:name "libyuv"))

+(define cmake-helpers-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/cmake_helpers.git"
+   #:revision "0"
+   #:commit "4d44d822e01b3b5fbec3ce824e01f56aa35d7f72"
+   #:hash "0h6cjiqy014h2mz90h1z5a7plb3ihbnds4bja8994ybr1dy3m7m5"
+   #:name "cmake-helpers"))
+
+(define codegen-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/codegen.git"
+   #:revision "0"
+   #:commit "248614b49cd7d5aff69d75a737f2e35b79fbb119"
+   #:hash "00f7g2z6xmkbkrmi3q27hscjl44mg66wf9q0mz3rhy3jaa6cfdrk"
+   #:name "codegen"))
+
+(define lib-base-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_base.git"
+   #:revision "0"
+   #:commit "a23c05c44e4f01dc4428f4d75d4db98c59d313a6"
+   #:hash "0vh5zgxwalmbnvz8lzlnba87ch8vnpmcz6nvf56w09f3nlxvvq78"
+   #:name "lib-base"))
+
+(define lib-crl-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_crl.git"
+   #:revision "0"
+   #:commit "3ccf2ed5095442e5874bba8852cb7dc4efeae29f"
+   #:hash "11my7q54m4lvvlgma6pbdyjxi1cv1adk1gph2j50mh18sqlm8myz"
+   #:name "lib-crl"))
+
+(define lib-lottie-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_lottie.git"
+   #:revision "0"
+   #:commit "0770df009db7928df1d0cad0900dc5110106d229"
+   #:hash "1gj56ymlbk5dnk82jw674808m511lv9dky8891a5wm4gp3pph5jb"
+   #:name "lib-lottie"))
+
+(define lib-qr-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_qr.git"
+   #:revision "0"
+   #:commit "2b08c71c6edcfc3e31f7d7f518cc963493b6e189"
+   #:hash "05hrkmwgrczyjv87r507i2r7m1zr6k2i43mq3my0s6j4szr1rjq0"
+   #:name "lib-qr"))
+
+(define lib-rlottie-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_rlottie.git"
+   #:revision "0"
+   #:commit "0671bf70547381effcf442ec9618e04502a8adbc"
+   #:hash "05qnza7j15356s8jq16pkbyp4zr586lssmd86lz5jq23lcb3raxv"
+   #:name "lib-rlottie"))
+
+(define lib-rpl-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_rpl.git"
+   #:revision "0"
+   #:commit "df721be3fa14a27dfc230d2e3c42bb1a7c9d0617"
+   #:hash "15fnv3ssn7rn5d0j52gggdvyqc2wm464678dj7v2x9h8lka2jjxn"
+   #:name "lib-rpl"))
+
+(define lib-spellcheck-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_spellcheck.git"
+   #:revision "0"
+   #:commit "68c9b788958904aea7de79f986a0f82ec8c5b094"
+   #:hash "0d8s4wwk6fxf536mhzq2vb9qw3j0m8nqia7ylvvpsbc4kh09dadn"
+   #:name "lib-spellcheck"))
+
+(define lib-storage-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_storage.git"
+   #:revision "0"
+   #:commit "403df6c4a29562bd417c92d410e49819f5a48cc1"
+   #:hash "1zxvzfrxbj4d395fzyb5pm9wn3n8jyimxx88cyqjcdd46sx4h7r5"
+   #:name "lib-storage"))
+
+(define lib-tl-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_tl.git"
+   #:revision "0"
+   #:commit "45faed44e7f4d11fec79b7a70e4a35dc91ef3fdb"
+   #:hash "0h43xvzklda02494d466jp52hl8c1kmav9f12dyld10dpf1w6c7m"
+   #:name "lib-tl"))
+
+(define lib-ui-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_ui.git"
+   #:revision "0"
+   #:commit "1b590f9e16eb9571a039f072d6fea66c607e419f"
+   #:hash "0ighyhfp29h9h8c7vr70pnhcv2xnsr9ln084pssn8hb5z4pmb62f"
+   #:name "lib-ui"))
+
+(define lib-waylandshells-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_waylandshells.git"
+   #:revision "0"
+   #:commit "59b0ee55a68976d27f1bf7cec0e11d5939e185e7"
+   #:hash "0l2xrpc5mvvdlsj333pmkgfvn9wi1ijfdaaz8skfnw9icw52faaf"
+   #:name "lib-waylandshells"))
+
+(define lib-webrtc-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_webrtc.git"
+   #:revision "0"
+   #:commit "ef49f953f12b112008a094a719f40939aaf39db4"
+   #:hash "15k4xs3462p3ddp5cn9im3nvdiaijmxir8wxsf5yrj70ghy26ibw"
+   #:name "lib-webrtc"))
+
+(define lib-webview-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/desktop-app/lib_webview.git"
+   #:revision "0"
+   #:commit "e06427c624515485774e2e2181d4afeb05ad5a67"
+   #:hash "148z7xzfscynwwwqssdsd97npax6yn8zrd64xw8qzbwff2g2r7k4"
+   #:name "lib-webview"))
+
+(define tgcalls-for-telegram-desktop
+  (source-for-telegram-desktop
+   #:url "https://github.com/TelegramMessenger/tgcalls.git"
+   #:revision "0"
+   #:commit "81e97fa52e25b7775b62ce07bb653533d81e91b3"
+   #:hash "0fvad87hyxli83xn19mgf8jjrrh6y6iaig14pckpbkg33vf4wqkj"
+   #:name "tgcalls"))
+
 (define-public webrtc-for-telegram-desktop
   (let ((commit "91d836dc84a16584c6ac52b36c04c0de504d9c34")
         (revision "166"))
@@ -292,294 +420,109 @@  (define-public telegram-desktop
                                           (cons* "." ".." keep)))))))))
     (build-system qt-build-system)
     (arguments
-     `(#:tests? #f                      ; No target
-       #:imported-modules
-       (,@%qt-build-system-modules
-        (guix build glib-or-gtk-build-system))
-       #:modules
-       ((guix build qt-build-system)
-        ((guix build glib-or-gtk-build-system)
-         #:prefix glib-or-gtk:)
-        (guix build utils)
-        (ice-9 match))
-       #:configure-flags
-       (list
-        ;; https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
-        ;; see also <https://core.telegram.org/api/obtaining_api_id>.
-        "-DTDESKTOP_API_ID=611335"
-        "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
-        ;; Disable WebkitGTK support as it fails to link
-        "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
-        ;; Use bundled fonts as fallback.
-        "-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'make-writable
-           (lambda _
-             (for-each make-file-writable (find-files "."))))
-         (add-after 'make-writable 'copy-inputs
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (for-each
-              (match-lambda
-                ((dst src)
-                 (copy-recursively src dst)
-                 (for-each make-file-writable (find-files dst))))
-              `(("cmake" ,(assoc-ref inputs "cmake-helpers"))
-                ("Telegram/codegen" ,(assoc-ref inputs "codegen-source"))
-                ("Telegram/lib_base" ,(assoc-ref inputs "lib-base-source"))
-                ("Telegram/lib_crl" ,(assoc-ref inputs "lib-crl-source"))
-                ("Telegram/lib_lottie"
-                 ,(assoc-ref inputs "lib-lottie-source"))
-                ("Telegram/lib_qr" ,(assoc-ref inputs "lib-qr-source"))
-                ("Telegram/lib_rlottie"
-                 ,(assoc-ref inputs "lib-rlottie-source"))
-                ("Telegram/lib_rpl" ,(assoc-ref inputs "lib-rpl-source"))
-                ("Telegram/lib_spellcheck"
-                 ,(assoc-ref inputs "lib-spellcheck-source"))
-                ("Telegram/lib_storage"
-                 ,(assoc-ref inputs "lib-storage-source"))
-                ("Telegram/lib_tl" ,(assoc-ref inputs "lib-tl-source"))
-                ("Telegram/lib_ui" ,(assoc-ref inputs "lib-ui-source"))
-                ("Telegram/lib_waylandshells" ,(assoc-ref inputs "lib-waylandshells-source"))
-                ("Telegram/lib_webrtc" ,(assoc-ref inputs "lib-webrtc-source"))
-                ("Telegram/lib_webview" ,(assoc-ref inputs "lib-webview-source"))
-                ("Telegram/ThirdParty/tgcalls" ,(assoc-ref inputs "tgcalls-source"))))))
-         (add-before 'configure 'patch-cxx-flags
-           (lambda _
-             (substitute* "cmake/options_linux.cmake" (("class-memaccess") "all"))))
-         (add-after 'install 'glib-or-gtk-compile-schemas
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
-         (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+     (list #:tests? #f                      ; No target
+           #:imported-modules
+           `(,@%qt-build-system-modules
+             (guix build glib-or-gtk-build-system))
+           #:modules
+           '((guix build qt-build-system)
+             ((guix build glib-or-gtk-build-system)
+              #:prefix glib-or-gtk:)
+             (guix build utils)
+             (ice-9 match))
+           #:configure-flags
+           #~`(;; https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+               ;; see also <https://core.telegram.org/api/obtaining_api_id>.
+               "-DTDESKTOP_API_ID=611335"
+               "-DTDESKTOP_API_HASH=d524b414d21f4d37f08684c1df41ac9c"
+               ;; Disable WebkitGTK support as it fails to link
+               "-DDESKTOP_APP_DISABLE_WEBKITGTK=ON"
+               ;; Use bundled fonts as fallback.
+               "-DDESKTOP_APP_USE_PACKAGED_FONTS=OFF")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'make-writable
+                 (lambda _
+                   (for-each make-file-writable (find-files "."))))
+               (add-after 'make-writable 'copy-sources
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   (for-each
+                    (match-lambda
+                      ((dst src)
+                       (copy-recursively src dst)
+                       (for-each make-file-writable (find-files dst))))
+                    '(("cmake" #$cmake-helpers-for-telegram-desktop)
+                      ("Telegram/codegen" #$codegen-for-telegram-desktop)
+                      ("Telegram/lib_base" #$lib-base-for-telegram-desktop)
+                      ("Telegram/lib_crl" #$lib-crl-for-telegram-desktop)
+                      ("Telegram/lib_lottie" #$lib-lottie-for-telegram-desktop)
+                      ("Telegram/lib_qr" #$lib-qr-for-telegram-desktop)
+                      ("Telegram/lib_rlottie" #$lib-rlottie-for-telegram-desktop)
+                      ("Telegram/lib_rpl" #$lib-rpl-for-telegram-desktop)
+                      ("Telegram/lib_spellcheck" #$lib-spellcheck-for-telegram-desktop)
+                      ("Telegram/lib_storage" #$lib-storage-for-telegram-desktop)
+                      ("Telegram/lib_tl" #$lib-tl-for-telegram-desktop)
+                      ("Telegram/lib_ui" #$lib-ui-for-telegram-desktop)
+                      ("Telegram/lib_waylandshells" #$lib-waylandshells-for-telegram-desktop)
+                      ("Telegram/lib_webrtc" #$lib-webrtc-for-telegram-desktop)
+                      ("Telegram/lib_webview" #$lib-webview-for-telegram-desktop)
+                      ("Telegram/ThirdParty/tgcalls" #$tgcalls-for-telegram-desktop)))))
+               (add-before 'configure 'patch-cxx-flags
+                 (lambda _
+                   (substitute* "cmake/options_linux.cmake" (("class-memaccess") "all"))))
+               (add-after 'install 'glib-or-gtk-compile-schemas
+                 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+               (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+                 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
     (native-inputs
-     (modify-inputs
-         `(("cmake-helpers"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/cmake_helpers.git")
-                 (commit "4d44d822e01b3b5fbec3ce824e01f56aa35d7f72")))
-               (file-name
-                (git-file-name
-                 "cmake-helpers-for-telegram-desktop" version))
-               (sha256
-                (base32
-                 "0h6cjiqy014h2mz90h1z5a7plb3ihbnds4bja8994ybr1dy3m7m5")))))
-       (append cmake-shared
-               extra-cmake-modules
-               `(,glib "bin")
-               `(,gtk+ "bin")
-               pkg-config
-               python-wrapper
-               qttools-5)))
+     (list cmake-shared
+           extra-cmake-modules
+           `(,glib "bin")
+           `(,gtk+ "bin")
+           pkg-config
+           python-wrapper
+           qttools-5))
     (inputs
-     (modify-inputs
-         `(("codegen-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/codegen.git")
-                 (commit "248614b49cd7d5aff69d75a737f2e35b79fbb119")))
-               (file-name
-                (git-file-name "codegen" version))
-               (sha256
-                (base32 "00f7g2z6xmkbkrmi3q27hscjl44mg66wf9q0mz3rhy3jaa6cfdrk"))))
-           ("lib-base-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_base.git")
-                 (commit "a23c05c44e4f01dc4428f4d75d4db98c59d313a6")))
-               (file-name
-                (git-file-name "lib-base-for-telegram-desktop" version))
-               (sha256
-                (base32 "0vh5zgxwalmbnvz8lzlnba87ch8vnpmcz6nvf56w09f3nlxvvq78"))))
-           ("lib-crl-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_crl.git")
-                 (commit "3ccf2ed5095442e5874bba8852cb7dc4efeae29f")))
-               (file-name
-                (git-file-name "lib-crl-for-telegram-desktop" version))
-               (sha256
-                (base32 "11my7q54m4lvvlgma6pbdyjxi1cv1adk1gph2j50mh18sqlm8myz"))))
-           ("lib-lottie-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_lottie.git")
-                 (commit "0770df009db7928df1d0cad0900dc5110106d229")))
-               (file-name
-                (git-file-name "lib-lottie-for-telegram-desktop" version))
-               (sha256
-                (base32 "1gj56ymlbk5dnk82jw674808m511lv9dky8891a5wm4gp3pph5jb"))))
-           ("lib-qr-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_qr.git")
-                 (commit "2b08c71c6edcfc3e31f7d7f518cc963493b6e189")))
-               (file-name
-                (git-file-name "lib-qr-for-telegram-desktop" version))
-               (sha256
-                (base32 "05hrkmwgrczyjv87r507i2r7m1zr6k2i43mq3my0s6j4szr1rjq0"))))
-           ("lib-rlottie-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_rlottie.git")
-                 (commit "0671bf70547381effcf442ec9618e04502a8adbc")))
-               (file-name
-                (git-file-name "lib-rlottie-for-telegram-desktop" version))
-               (sha256
-                (base32 "05qnza7j15356s8jq16pkbyp4zr586lssmd86lz5jq23lcb3raxv"))))
-           ("lib-rpl-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_rpl.git")
-                 (commit "df721be3fa14a27dfc230d2e3c42bb1a7c9d0617")))
-               (file-name
-                (git-file-name "lib-rpl-for-telegram-desktop" version))
-               (sha256
-                (base32 "15fnv3ssn7rn5d0j52gggdvyqc2wm464678dj7v2x9h8lka2jjxn"))))
-           ("lib-spellcheck-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_spellcheck.git")
-                 (commit "68c9b788958904aea7de79f986a0f82ec8c5b094")))
-               (file-name
-                (git-file-name "lib-spellcheck-for-telegram-desktop" version))
-               (sha256
-                (base32 "0d8s4wwk6fxf536mhzq2vb9qw3j0m8nqia7ylvvpsbc4kh09dadn"))))
-           ("lib-storage-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_storage.git")
-                 (commit "403df6c4a29562bd417c92d410e49819f5a48cc1")))
-               (file-name
-                (git-file-name "lib-storage-for-telegram-desktop" version))
-               (sha256
-                (base32 "1zxvzfrxbj4d395fzyb5pm9wn3n8jyimxx88cyqjcdd46sx4h7r5"))))
-           ("lib-tl-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_tl.git")
-                 (commit "45faed44e7f4d11fec79b7a70e4a35dc91ef3fdb")))
-               (file-name
-                (git-file-name "lib-tl-for-telegram-desktop" version))
-               (sha256
-                (base32 "0h43xvzklda02494d466jp52hl8c1kmav9f12dyld10dpf1w6c7m"))))
-           ("lib-ui-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_ui.git")
-                 (commit "1b590f9e16eb9571a039f072d6fea66c607e419f")))
-               (file-name
-                (git-file-name "lib-ui-for-telegram-desktop" version))
-               (sha256
-                (base32 "0ighyhfp29h9h8c7vr70pnhcv2xnsr9ln084pssn8hb5z4pmb62f"))))
-           ("lib-waylandshells-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_waylandshells.git")
-                 (commit "59b0ee55a68976d27f1bf7cec0e11d5939e185e7")))
-               (file-name
-                (git-file-name "lib-waylandshells-for-telegram-desktop" version))
-               (sha256
-                (base32 "0l2xrpc5mvvdlsj333pmkgfvn9wi1ijfdaaz8skfnw9icw52faaf"))))
-           ("lib-webrtc-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_webrtc.git")
-                 (commit "ef49f953f12b112008a094a719f40939aaf39db4")))
-               (file-name
-                (git-file-name "lib-webrtc-for-telegram-desktop" version))
-               (sha256
-                (base32 "15k4xs3462p3ddp5cn9im3nvdiaijmxir8wxsf5yrj70ghy26ibw"))))
-           ("lib-webview-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/desktop-app/lib_webview.git")
-                 (commit "e06427c624515485774e2e2181d4afeb05ad5a67")))
-               (file-name
-                (git-file-name "lib-webview-for-telegram-desktop" version))
-               (sha256
-                (base32 "148z7xzfscynwwwqssdsd97npax6yn8zrd64xw8qzbwff2g2r7k4"))))
-           ("tgcalls-source"
-            ,(origin
-               (method git-fetch)
-               (uri
-                (git-reference
-                 (url "https://github.com/TelegramMessenger/tgcalls.git")
-                 (commit "81e97fa52e25b7775b62ce07bb653533d81e91b3")))
-               (file-name
-                (git-file-name "tgcalls-for-telegram-desktop" version))
-               (sha256
-                (base32 "0fvad87hyxli83xn19mgf8jjrrh6y6iaig14pckpbkg33vf4wqkj")))))
-       (append alsa-lib
-               c++-gsl
-               catch2
-               libexpected
-               fcitx-qt5
-               fcitx5-qt
-               ffmpeg
-               glib
-               glibmm-2.64
-               gtk+
-               hime
-               hunspell
-               jemalloc
-               kwayland
-               libdbusmenu-qt
-               libjpeg-turbo
-               libtgvoip-for-telegram-desktop
-               lz4
-               materialdecoration
-               minizip
-               nimf
-               openal
-               openssl
-               opus
-               pulseaudio
-               qrcodegen-cpp
-               qtbase-5
-               qtsvg-5
-               qt5ct
-               qtimageformats
-               qtwayland
-               range-v3
-               rlottie-for-telegram-desktop
-               rnnoise
-               webrtc-for-telegram-desktop
-               libx11
-               libxcb
-               xcb-util-keysyms
-               xxhash
-               zlib)))
+     (list alsa-lib
+           c++-gsl
+           catch2
+           libexpected
+           fcitx-qt5
+           fcitx5-qt
+           ffmpeg
+           glib
+           glibmm-2.64
+           gtk+
+           hime
+           hunspell
+           jemalloc
+           kwayland
+           libdbusmenu-qt
+           libjpeg-turbo
+           libtgvoip-for-telegram-desktop
+           lz4
+           materialdecoration
+           minizip
+           nimf
+           openal
+           openssl
+           opus
+           pulseaudio
+           qrcodegen-cpp
+           qtbase-5
+           qtsvg-5
+           qt5ct
+           qtimageformats
+           qtwayland
+           range-v3
+           rlottie-for-telegram-desktop
+           rnnoise
+           webrtc-for-telegram-desktop
+           libx11
+           libxcb
+           xcb-util-keysyms
+           xxhash
+           zlib))
     (propagated-inputs (list dconf))
     (synopsis "Telegram Desktop")
     (description "Telegram desktop is the official desktop version of the