diff mbox series

[bug#61865,4/8] gnu: mtdev: fix riscv64 cross-compile.

Message ID tencent_EE34E5AE2576B5BE9B4AA9CE596C7F7E3A08@qq.com
State New
Headers show
Series fix some packages cross-compile | expand

Commit Message

Z572 Feb. 28, 2023, 8:33 a.m. UTC
* gnu/packages/xdisorg.scm(mtdev): fix riscv64 cross-compile
[arguments]: when target is riscv64, add phase to update config.{guess,sub}.
[native-inputs]: when target is riscv64, add config.
---
 gnu/packages/xdisorg.scm | 20 ++++++++++++++++++--
 1 file changed, 18 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2ebeb4e013..21bc368538 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -41,7 +41,7 @@ 
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2020 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
-;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2020, 2021, 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
@@ -763,7 +763,23 @@  (define-public mtdev
          (base32
           "1q700h9dqcm3zl6c3gj0qxxjcx6ibw2c51wjijydhwdcm26v5mqm"))))
     (build-system gnu-build-system)
-    (arguments '(#:configure-flags '("--disable-static")))
+    (arguments `(#:configure-flags '("--disable-static")
+                 ,@(if (target-riscv64?)
+                       `(#:phases
+                         (modify-phases %standard-phases
+                           (add-after 'unpack 'update-config-scripts
+                             (lambda* (#:key inputs native-inputs #:allow-other-keys)
+                               ;; Replace outdated config.guess and config.sub.
+                               (for-each (lambda (file)
+                                           (install-file
+                                            (search-input-file
+                                             (or native-inputs inputs)
+                                             (string-append "/bin/" file)) "./config-aux"))
+                                         '("config.guess" "config.sub"))))))
+                       '())))
+    (native-inputs (if (target-riscv64?)
+                       (list config)
+                       '()))
     (home-page "http://bitmath.org/code/mtdev/")
     (synopsis "Multitouch protocol translation library")
     (description "Mtdev is a stand-alone library which transforms all