diff mbox series

[bug#63065,12/18] gnu: Add rust-rustyline-derive-0.6.

Message ID oSXWjJ5If5ZAidWGXUewaaLe8ir94V8EiVUcpaTt04lrGrR4T4vB9XcLKg1WDdELy7BRaZl6NCclYULL5__gSjSTw3mWwVaCN0W2XwrVWos=@proton.me
State New
Headers show
Series : gnu: Add yabridgectl. | expand

Commit Message

Sughosha April 25, 2023, 9:33 a.m. UTC
* gnu/packages/crates-io.scm (rust-rustyline-derive-0.6): New variable.
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5c34d1eadf..0e35b92493 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49607,6 +49607,28 @@  (define-public rust-rustyline-5
         ("rust-rustyline-derive" ,rust-rustyline-derive-0.2)
         ("rust-tempdir" ,rust-tempdir-0.3))))))
 
+(define-public rust-rustyline-derive-0.6
+  (package
+    (name "rust-rustyline-derive")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustyline-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0mw0nfi8xxsm4q80mv4va7ff8m0kgnsfjvv067zc1d8hp1daaddv"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/kkawakam/rustyline")
+    (synopsis "Rustyline macros implementation in Rust")
+    (description
+     "This package provides Rustyline macros implementation in Rust.")
+    (license license:expat)))
+
 (define-public rust-rustyline-derive-0.3
   (package
     (name "rust-rustyline-derive")