diff mbox series

[bug#63065,02/18] gnu: Add bitsery.

Message ID lP_IXzJsdLemjFYWXJhdqcDDO8w91YysiNN6bmeaoQYXNu709dVk3hdxzrL9-7HEcY4nGL-_ZpWroxKY0GHAE1bor4iF6oWMCZVrpEBKY8U=@proton.me
State New
Headers show
Series : gnu: Add yabridgectl. | expand

Commit Message

Sughosha April 25, 2023, 9:27 a.m. UTC
* gnu/packages/cpp.scm (bitsery): New variable.
---
 gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ed6ae69198..699d0cacb1 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1982,6 +1982,30 @@  (define-public gulrak-filesystem
     (home-page "https://github.com/gulrak/filesystem")
     (license license:expat)))
 
+(define-public bitsery
+  (package
+    (name "bitsery")
+    (version "5.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fraillt/bitsery")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hv2fya7w53bfhlk79b1qnjg1qy076s8kvg22sfdq05bh0hxqrxf"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags #~(list "-DBITSERY_BUILD_TESTS=ON")))
+    (native-inputs (list googletest))
+    (synopsis "Header only C++ binary serialization library")
+    (description "This package provides header only C++ binary serialization
+library.  It is designed around the networking requirements for real-time data
+delivery, especially for games.")
+    (home-page "https://github.com/fraillt/bitsery")
+    (license license:expat)))
+
 (define-public cpp-mustache
   (package
     (name "cpp-mustache")