diff mbox series

[bug#50663,14/19] gnu: Add python-gtts.

Message ID k2qw9zW5ZxTsP9Fcdc5GZTAB8vMzZpVmmqW5PvwDbfZD8O7x6ZxDnuFAAAisjEXEIjOkHN-eA6C6royUJqZW71--_hI-CoOhHa7j4QnG9p0=@protonmail.com
State New
Headers show
Series [bug#50663,01/18] gnu: Add python-pyee. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 7:04 p.m. UTC
* gnu/packages/python-xyz.scm (python-gtts): New variable.

--
2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c068ee17b..46e5c2522d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16371,6 +16371,37 @@  A GraphQL schema describes your data model, and provides a GraphQL server
 with an associated set of resolve methods that know how to fetch data.")
     (license license:expat)))

+(define-public python-gtts
+  (package
+    (name "python-gtts")
+    (version "2.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gTTS" version))
+       (sha256
+        (base32
+         "03qah9gxhx8m6apviqyffay2dpijm2k5h88ikzgndyvs6zc18dxm"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-flake8" ,python-flake8)
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-cov" ,python-pytest-cov)
+       ("python-six" ,python-six)
+       ("python-testfixtures" ,python-testfixtures)))
+    (propagated-inputs
+     `(("python-click" ,python-click)
+       ("python-requests" ,python-requests)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/pndurette/gTTS")
+    (synopsis
+     "Python interface to Google Translate text-to-speech API")
+    (description
+     "Python library and CLI tool to interface with Google Translate
+text-to-speech API")
+    (license license:expat)))
+
 (define-public python-nautilus
   (package
     (name "python-nautilus")