diff mbox series

[bug#50663,07/19] gnu: Add python-lazy.

Message ID OLY7gCvWS6mxjo6zqJ-e0uHKyDZhiFuHUMI5LdoUt-PEbnNGunQRCV26x3w9mtl8bhb1IdZAngtcJ7JELOvEC_RdvzP2f-JxK3M-9g7sitU=@protonmail.com
State New
Headers show
Series [bug#50663,01/18] gnu: Add python-pyee. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 7:01 p.m. UTC
* gnu/packages/python-xyz.scm (python-lazy): New variable.

--
2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b1a26f603..8f92800112 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15254,6 +15254,28 @@  feels like an AST.")
 inspection of types defined in the Python standard typing module.")
     (license license:expat)))

+(define-public python-lazy
+  (package
+    (name "python-lazy")
+    (version "1.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference   ; pypi release link leads to project page
+             (url "https://github.com/stefanholek/lazy")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1y3y35jr0nnfh32zgdrb4r4sf9v8k36j07z2m0g6kz7bf3azsgc5"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/stefanholek/lazy")
+    (synopsis "Lazy attributes for Python objects")
+    (description "Provides lazy attributes that are evaluated only once,
+the first time they are used.  Subsequent uses return the results of the first
+call.")
+    (license license:bsd-2)))
+
 (define-public python-lazy-object-proxy
   (package
     (name "python-lazy-object-proxy")