diff mbox series

[bug#65500,2/2] gnu: Add r-mousegastrulationdata.

Message ID feee7c4944e8282a6f8b848dc17bff2993b8ff56.1692883708.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65499,1/2] gnu: Add r-bumpymatrix. | expand

Commit Message

nafkhamdc Aug. 24, 2023, 1:28 p.m. UTC
* gnu/packages/bioconductor.scm (r-mousegastrulationdata): New variable.
---
 gnu/packages/bioconductor.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ricardo Wurmus Aug. 28, 2023, 8:20 a.m. UTC | #1
Applied with minor changes:

- location in the file, next to other experiment packages
- formatting of the description.
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6204173277..f3671e5cca 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8009,6 +8009,37 @@  (define-public r-motifrg
 throughput genetic sequencing data sets using regression methods.")
     (license license:artistic2.0)))
 
+(define-public r-mousegastrulationdata
+  (package
+    (name "r-mousegastrulationdata")
+    (version "1.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "MouseGastrulationData" version
+                                     'experiment))
+              (sha256
+               (base32
+                "155kci5isq7mlbvv8mdl2jjpafm3pbv1likhls70aa746spr1h17"))))
+    (properties `((upstream-name . "MouseGastrulationData")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biocgenerics
+                             r-bumpymatrix
+                             r-experimenthub
+                             r-s4vectors
+                             r-singlecellexperiment
+                             r-spatialexperiment
+                             r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/MarioniLab/MouseGastrulationData")
+    (synopsis
+     "Single-Cell omics data across mouse gastrulation and early organogenesis")
+    (description
+     "This package provides processed and raw count data for single-cell RNA sequencing.
+in addition, this package offers single-cell ATAC-seq, and @code{seqFISH}
+(spatial transcriptomic) experiments performed along a timecourse of mouse
+gastrulation and early organogenesis.")
+    (license license:gpl3)))
+
 (define-public r-muscat
   (package
     (name "r-muscat")