diff mbox series

[bug#65499,1/2] gnu: Add r-bumpymatrix.

Message ID c6cead75b569c3dd196e91ff76d557f8969f9a41.1692883708.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65499,1/2] gnu: Add r-bumpymatrix. | expand

Commit Message

nafkhamdc Aug. 24, 2023, 1:28 p.m. UTC
* gnu/packages/bioconductor.scm (r-bumpymatrix): New variable.
---
 gnu/packages/bioconductor.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 39fa1ef033fda82cb1d122e0d1675b51acb1db34

Comments

Ricardo Wurmus Aug. 28, 2023, 8:20 a.m. UTC | #1
Applied with minor changes.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 74071900a3..6204173277 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12913,6 +12913,33 @@  (define-public r-siggenes
 Bayes Analyses of Microarrays} (EBAM).")
     (license license:lgpl2.0+)))
 
+(define-public r-bumpymatrix
+  (package
+    (name "r-bumpymatrix")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BumpyMatrix" version))
+              (sha256
+               (base32
+                "021xn5d08phmwv6g8a5d4ap5kcf5syhm6vpr784l4k54lflssr5i"))))
+    (properties `((upstream-name . "BumpyMatrix")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-iranges r-matrix r-s4vectors))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BumpyMatrix")
+    (synopsis "Bumpy matrix of non-scalar objects")
+    (description
+     "
+@code{BumpyMatrix} class and subclasses for storing non-scalar objects in matrix entries.
+This is akin to a ragged array but the raggedness is in the third dimension,
+much like a bumpy surface - hence the name.  Of particular interest is the
+@code{BumpyDataFrameMatrix,} where each entry is a Bioconductor data frame.
+This allows us to naturally represent multivariate data in a format that is
+compatible with two-dimensional containers like the @code{SummarizedExperiment}
+and @code{MultiAssayExperiment} objects.")
+    (license license:expat)))
+
 (define-public r-bumphunter
   (package
     (name "r-bumphunter")