[bug#70913,08/11] gnu: Use new ovmf firmware packages.
Commit Message
* doc/guix.texi (Invoking guix system): Update qemu command to use
ovmf-x86-64.
* gnu/packages/virtualization.scm (xen)[inputs]: Replace ovmf with
ovmf-i686.
* gnu/tests/install.scm (uefi-firmware): Use system appropriate ovmf
firmware.
Change-Id: Ia2ff76eaf766c8d4fb0be4a7cc7b8941574433d0
---
doc/guix.texi | 2 +-
gnu/packages/virtualization.scm | 2 +-
gnu/tests/install.scm | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
@@ -42250,7 +42250,7 @@ Invoking guix system
cp $image /tmp/my-image.qcow2
chmod +w /tmp/my-image.qcow2
qemu-system-x86_64 -enable-kvm -hda /tmp/my-image.qcow2 -m 1000 \
- -bios $(guix build ovmf)/share/firmware/ovmf_x64.bin
+ -bios $(guix build ovmf-x86-64)/share/firmware/ovmf_x64.bin
@end example
When using the @code{mbr-hybrid-raw} image type, a raw disk image is
@@ -2670,7 +2670,7 @@ (define-public xen
yajl
ncurses
openssl
- ovmf
+ ovmf-i686
pixman
qemu-minimal
seabios
@@ -210,9 +210,9 @@ (define (uefi-firmware system)
"Return the appropriate QEMU OVMF UEFI firmware for the given SYSTEM."
(cond
((string-prefix? "x86_64" system)
- (file-append ovmf "/share/firmware/ovmf_x64.bin"))
+ (file-append ovmf-x86-64 "/share/firmware/ovmf_x64.bin"))
((string-prefix? "i686" system)
- (file-append ovmf "/share/firmware/ovmf_ia32.bin"))
+ (file-append ovmf-i686 "/share/firmware/ovmf_ia32.bin"))
(else #f)))
(define* (run-install target-os target-os-source