[bug#70913,02/11] gnu: edk2-tools: Enable submodules.
Commit Message
* gnu/packages/firmware.scm (edk2-tools)[source]: Checkout submodules.
[arguments]: Don't disable building brotli or xz compression.
Change-Id: I8b318373e38767e1a309e9e385f1626429bfbb20
---
gnu/packages/firmware.scm | 15 ++++-----------
1 file changed, 4 insertions(+), 11 deletions(-)
@@ -819,11 +819,13 @@ (define-public edk2-tools
(method git-fetch)
(uri (git-reference
(url "https://github.com/tianocore/edk2")
- (commit (string-append "edk2-stable" version))))
+ (commit (string-append "edk2-stable" version))
+ ;; EDK2 makes extensive use of submodules.
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "1x0h89cz3ihihcp4n93bw708q9r3icprb8cjsrrfcgq10clavdzx"))))
+ "0y7jfpijgi099znhzjklnsczn0k0vm1d1qznq9x2a2sa0glydsin"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags
@@ -835,15 +837,6 @@ (define-public edk2-tools
(add-after 'unpack 'change-directory
(lambda _
(chdir "BaseTools")))
- (add-after 'change-directory 'disable-some-tools
- (lambda _
- ;; Disable building brotli and xz, since we package them
- ;; separately, and it would require fetching submodules.
- (substitute* "Source/C/GNUmakefile"
- (("^[[:blank:]]+BrotliCompress[[:blank:]]+\\\\")
- "\\")
- (("^[[:blank:]]+LzmaCompress[[:blank:]]+\\\\")
- "\\"))))
(replace 'build
(lambda* (#:key (make-flags #~'()) #:allow-other-keys)
;; The default build target also runs tests.