diff mbox series

[bug#70913,02/11] gnu: edk2-tools: Enable submodules.

Message ID a30ff9235726df67f90dba40bbccb4da634f329f.1715588342.git.efraim@flashner.co.il
State New
Headers show
Series Combine edk2-tools and ovmf firmware | expand

Commit Message

Efraim Flashner May 13, 2024, 8:21 a.m. UTC
* gnu/packages/firmware.scm (edk2-tools)[source]: Checkout submodules.
[arguments]: Don't disable building brotli or xz compression.

Change-Id: I8b318373e38767e1a309e9e385f1626429bfbb20
---
 gnu/packages/firmware.scm | 15 ++++-----------
 1 file changed, 4 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 62753e3769..f3bb51bcb1 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -819,11 +819,13 @@  (define-public edk2-tools
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/tianocore/edk2")
-                    (commit (string-append "edk2-stable" version))))
+                    (commit (string-append "edk2-stable" version))
+                    ;; EDK2 makes extensive use of submodules.
+                    (recursive? #t)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1x0h89cz3ihihcp4n93bw708q9r3icprb8cjsrrfcgq10clavdzx"))))
+                "0y7jfpijgi099znhzjklnsczn0k0vm1d1qznq9x2a2sa0glydsin"))))
     (build-system gnu-build-system)
     (arguments
      (list #:make-flags
@@ -835,15 +837,6 @@  (define-public edk2-tools
                (add-after 'unpack 'change-directory
                  (lambda _
                    (chdir "BaseTools")))
-               (add-after 'change-directory 'disable-some-tools
-                 (lambda _
-                   ;; Disable building brotli and xz, since we package them
-                   ;; separately, and it would require fetching submodules.
-                   (substitute* "Source/C/GNUmakefile"
-                     (("^[[:blank:]]+BrotliCompress[[:blank:]]+\\\\")
-                      "\\")
-                     (("^[[:blank:]]+LzmaCompress[[:blank:]]+\\\\")
-                      "\\"))))
                (replace 'build
                  (lambda* (#:key (make-flags #~'()) #:allow-other-keys)
                    ;; The default build target also runs tests.