diff mbox series

[bug#66689,gnome-team,03/14] gnu: appstream-glib: Update to 0.8.2.

Message ID fde335982413688c0ad22d454aa412359b6856ec.1698006808.git.vivien@planete-kraus.eu
State New
Headers show
Series Update everything in (gnu packages glib) | expand

Commit Message

Vivien Kraus Oct. 22, 2023, 2:26 p.m. UTC
* gnu/packages/glib.scm (appstream-glib): Update to 0.8.2.
[inputs]: replace libsoup with curl.
---
 gnu/packages/glib.scm | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

Comments

Maxim Cournoyer Oct. 23, 2023, 1:36 a.m. UTC | #1
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> * gnu/packages/glib.scm (appstream-glib): Update to 0.8.2.
> [inputs]: replace libsoup with curl.

[...]

> -     `(("glib" ,glib)
> -       ("gperf" ,gperf)
> -       ("gtk+" ,gtk+)
> -       ("json-glib" ,json-glib)
> -       ("libarchive" ,libarchive)
> -       ("libsoup" ,libsoup-minimal-2)))
> +     (list
> +      glib
> +      gperf
> +      gtk+
> +      json-glib
> +      libarchive
> +      curl))

This indentation is unconventional; typically we'd use:

(list glib
      gperf
      ...)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 89fab8d8a5..df61d2d335 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -45,6 +45,7 @@  (define-module (gnu packages glib)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages docbook)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages elf)
@@ -1293,7 +1294,7 @@  (define-public sdbus-c++
 (define-public appstream-glib
   (package
     (name "appstream-glib")
-    (version "0.7.18")
+    (version "0.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://people.freedesktop.org/~hughsient/"
@@ -1301,7 +1302,7 @@  (define-public appstream-glib
                                   "appstream-glib-" version ".tar.xz"))
               (sha256
                (base32
-                "00j0kkgf224nzmrha72g8pd72mymhph7vaisj35i4ffy7cpd47na"))))
+                "15lbrmyx94cf6p6svq02yiskh31xidq092c711pqs16mml06a9bi"))))
     (build-system meson-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
@@ -1313,12 +1314,13 @@  (define-public appstream-glib
        ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
        ("libuuid" ,util-linux "lib"))) ; for .pc file
     (inputs
-     `(("glib" ,glib)
-       ("gperf" ,gperf)
-       ("gtk+" ,gtk+)
-       ("json-glib" ,json-glib)
-       ("libarchive" ,libarchive)
-       ("libsoup" ,libsoup-minimal-2)))
+     (list
+      glib
+      gperf
+      gtk+
+      json-glib
+      libarchive
+      curl))
     (arguments
      `(#:configure-flags
        (list "-Ddep11=false"