diff mbox series

[bug#66689,gnome-team,14/14] gnu: dbus: Update to 1.15.8.

Message ID 820c3f421a100a2d958f5507334eb57c7c2435f0.1698006808.git.vivien@planete-kraus.eu
State New
Headers show
Series Update everything in (gnu packages glib) | expand

Commit Message

Vivien Kraus Oct. 22, 2023, 8:30 p.m. UTC
* gnu/packages/glib.scm (dbus): Update to 1.15.8.
[native-inputs]: Add the autotools and which.
---
 gnu/packages/glib.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

Comments

Liliana Marie Prikler Oct. 22, 2023, 10:46 p.m. UTC | #1
Am Sonntag, dem 22.10.2023 um 22:30 +0200 schrieb Vivien Kraus:
> * gnu/packages/glib.scm (dbus): Update to 1.15.8.
> [native-inputs]: Add the autotools and which.
Heads up, dbus uses ye olde gnome versioning, so 1.14 is stable.

Cheers
Maxim Cournoyer Oct. 23, 2023, 1:41 a.m. UTC | #2
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 22.10.2023 um 22:30 +0200 schrieb Vivien Kraus:
>> * gnu/packages/glib.scm (dbus): Update to 1.15.8.
>> [native-inputs]: Add the autotools and which.
> Heads up, dbus uses ye olde gnome versioning, so 1.14 is stable.

These version scheme discrepancies within the same project is so
annoying that sometimes I think we just shouldn't pay much attention to
it.  I think Fedora actually uses whatever is the latest, so it's also
be a stretch to call latest 'unstable', as in experimental buggy
software.
Maxim Cournoyer Oct. 23, 2023, 1:42 a.m. UTC | #3
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> * gnu/packages/glib.scm (dbus): Update to 1.15.8.
> [native-inputs]: Add the autotools and which.

'autotools' is not a package.  Maybe use etc/committer.scm if you
don't want to spell it all out :-).

> ---
>  gnu/packages/glib.scm | 12 +++++++++---
>  1 file changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
> index 9f8c0dff11..ec0b8a3eca 100644
> --- a/gnu/packages/glib.scm
> +++ b/gnu/packages/glib.scm
> @@ -37,6 +37,7 @@
>  
>  (define-module (gnu packages glib)
>    #:use-module (gnu packages)
> +  #:use-module (gnu packages autotools)
>    #:use-module (gnu packages backup)
>    #:use-module (gnu packages base)
>    #:use-module (gnu packages bash)
> @@ -106,7 +107,7 @@ (define-module (gnu packages glib)
>  (define dbus
>    (package
>      (name "dbus")
> -    (version "1.14.0")
> +    (version "1.15.8")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append
> @@ -114,7 +115,7 @@ (define dbus
>                      version ".tar.xz"))
>                (sha256
>                 (base32
> -                "1m7bibavml4gx9d67j403l0kzd1a4z8lhrpxb2as3q4nfpiwrmyc"))
> +                "016j3rqc8m62bg0h7z4rpvbvm5bg0hbjrld733f0aby8drz5kz44"))
>                (patches (search-patches "dbus-helper-search-path.patch"))))
>      (build-system gnu-build-system)
>      (arguments
> @@ -156,7 +157,12 @@ (define dbus
>             xmlto
>             libxml2 ;for XML_CATALOG_FILES
>             libxslt
> -           yelp-tools))
> +           yelp-tools
> +           which
> +           libtool
> +           automake
> +           autoconf
> +           autoconf-archive))

Looks like you'll want to select them inputs and call M-x sort-lines on
them.
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 9f8c0dff11..ec0b8a3eca 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -37,6 +37,7 @@ 
 
 (define-module (gnu packages glib)
   #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bash)
@@ -106,7 +107,7 @@  (define-module (gnu packages glib)
 (define dbus
   (package
     (name "dbus")
-    (version "1.14.0")
+    (version "1.15.8")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -114,7 +115,7 @@  (define dbus
                     version ".tar.xz"))
               (sha256
                (base32
-                "1m7bibavml4gx9d67j403l0kzd1a4z8lhrpxb2as3q4nfpiwrmyc"))
+                "016j3rqc8m62bg0h7z4rpvbvm5bg0hbjrld733f0aby8drz5kz44"))
               (patches (search-patches "dbus-helper-search-path.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -156,7 +157,12 @@  (define dbus
            xmlto
            libxml2 ;for XML_CATALOG_FILES
            libxslt
-           yelp-tools))
+           yelp-tools
+           which
+           libtool
+           automake
+           autoconf
+           autoconf-archive))
     (inputs
      (list expat
            ;; Add a dependency on libx11 so that 'dbus-launch' has support for