diff mbox series

[bug#63641,8/8] gnu: hurd: Update to v0.9.git20230216.

Message ID fcb36b13b0b5be42c07d477871ff604c1dc5178e.1684745752.git.dev@jpoiret.xyz
State New
Headers show
Series Add libc specific to Hurd and update components | expand

Commit Message

Josselin Poiret May 22, 2023, 9:04 a.m. UTC
From: Josselin Poiret <dev@jpoiret.xyz>

* gnu/packages/hurd.scm (hurd-headers): Update to v0.9.git20230216.
---
 gnu/packages/hurd.scm | 14 ++++++--------
 1 file changed, 6 insertions(+), 8 deletions(-)

Comments

Ludovic Courtès May 24, 2023, 8:48 a.m. UTC | #1
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

> From: Josselin Poiret <dev@jpoiret.xyz>
>
> * gnu/packages/hurd.scm (hurd-headers): Update to v0.9.git20230216.

[...]

> +++ b/gnu/packages/hurd.scm
> @@ -144,10 +144,10 @@ (define-public hurd-headers
>    ;; This commit is now slightly behind 0.9.git20220818 as this one needs a
>    ;; newer glibc
>    (let ((revision "2")
> -        (commit "3ff70531ee672f431dbb0c11f286bfe85dce98fc"))
> +        (commit "v0.9.git20230216"))

Could you update or remove the comment above?

Also I wonder if we should use the actual commit ID rather than this
tag, since the tag doesn’t even denote a release.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 61d8774075..a0133482b7 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -144,10 +144,10 @@  (define-public hurd-headers
   ;; This commit is now slightly behind 0.9.git20220818 as this one needs a
   ;; newer glibc
   (let ((revision "2")
-        (commit "3ff70531ee672f431dbb0c11f286bfe85dce98fc"))
+        (commit "v0.9.git20230216"))
     (package
       (name "hurd-headers")
-      (version (git-version "0.9" revision commit))
+      (version commit)
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -155,11 +155,8 @@  (define-public hurd-headers
                       (commit commit)))
                 (sha256
                  (base32
-                  "1jb9f2h2v4lf6acsji1c12aqg3pixkvjdyb4q6axkd8jp22fdgc0"))
-                (file-name (git-file-name name version))
-                (patches (search-patches "hurd-add-without-rump-configure-option.patch"
-                                         "hurd-fix-types-of-read-write-and-readables-methods.patch"
-                                         "hurd-fix-types-of-read-write-and-readables-methods-2.patch"))))
+                  "0jm1dnqkx4kdwmby0z5w0yqp9m5qp4hbxd4jxlyhiqm8nkw9mkvv"))
+                (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (native-inputs
        (list autoconf
@@ -196,7 +193,8 @@  (define-public hurd-headers
                              "ac_cv_func_exec_exec_paths=no"
                              "ac_cv_func__hurd_exec_paths=no"
                              "ac_cv_func__hurd_libc_proc_init=no"
-                             "ac_cv_func_file_futimens=no")
+                             "ac_cv_func_file_futimens=no"
+                             "ac_cv_lib_acpica_acpi_init=no")
 
          #:tests? #f))
       (supported-systems %hurd-systems)