diff mbox series

[bug#55753] gnu: Add emacs-color-theme-modern.

Message ID fc347a502d5755b72b90b92f9b6254c6312f950b.1654097985.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55753] gnu: Add emacs-color-theme-modern. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro June 1, 2022, 3:41 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/emacs-xyz.scm (emacs-color-theme-modern): New variable.
---
 gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Liliana Marie Prikler June 2, 2022, 6:09 a.m. UTC | #1
Am Mittwoch, dem 01.06.2022 um 11:41 -0400 schrieb peter@polidoro.io:
> +(define-public emacs-color-theme-modern
> +  (package
> +    (name "emacs-color-theme-modern")
> +    (version "20220506.858")
We don't do MELPA versions.  Use "0.0.3" as base version, and...

> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://github.com/emacs-jp/replace-colorthemes.git")
> +                    (commit
> "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")))
... use git-version for non-release commits.  It's also always nice to
include a helpful message as to why you're building a non-release
commit, in this case that'd be "No release since October 2019."

> +              (sha256
> +               (base32
> +               
> "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
> +    (build-system emacs-build-system)
> +    (home-page "https://github.com/emacs-jp/replace-colorthemes")
> +    (synopsis "Over one hundred Emacs themes ported from color-
> theme")
No ads.

> +    (description "Over one hundred Emacs themes, including aalto-
> dark,
> +aalto-light, aliceblue, andreas, arjen, beige-diff, beige-eshell,
> +bharadwaj-slate, bharadwaj, billw, black-on-gray, blippblopp, blue-
> erc,
> +blue-eshell, blue-gnus, blue-mood, blue-sea, calm-forest, charcoal-
> black,
> +clarity, classic, cobalt, comidia, dark-blue, dark-blue2, dark-erc,
> +dark-font-lock, dark-gnus, dark-green, dark-info, dark-laptop, deep-
> blue,
> +desert, digital-ofs1, emacs-21, emacs-nw, euphoria, feng-shui,
> fischmeister,
> +gnome, gnome2, goldenrod, gray1, gray30, greiner, gtk-ide, high-
> contrast,
> +hober, infodoc, jb-simple, jedit-grey, jonadabian-slate, jonadabian,
> jsc-dark,
> +jsc-light, jsc-light2, julie, katester, kingsajz, late-night,
> lawrence,
> +ld-dark, lethe, marine, marquardt, matrix, midnight, mistyday,
> montz, oswald,
> +parus, pierson, pok-wob, pok-wog, railscast, ramangalahy,
> raspopovic,
> +renegade, resolve, retro-green, retro-orange, robin-hood, rotor,
> ryerson,
> +salmon-diff, salmon-font-lock, scintilla, shaman, simple-1,
> sitaramv-nt,
> +sitaramv-solaris, snow, snowish, standard-ediff, standard, subdued,
> +subtle-blue, subtle-hacker, taming-mr-arneson, taylor, tty-dark,
> vim-colors,
> +whateveryouwant, wheat, word-perfect, xemacs, xp")
No ads.  Write something like "This package contains several themes
that were originally implemented with the venerable @code{color-themes}
package, ported to Emacs' built-in custom themes."

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 22d723c879..7612832173 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -109,6 +109,7 @@ 
 ;;; Copyright © 2022 Brandon Lucas <br@ndon.dk>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2873,6 +2874,40 @@  (define-public emacs-auctex
 or XEmacs.")
     (license license:gpl3+)))
 
+(define-public emacs-color-theme-modern
+  (package
+    (name "emacs-color-theme-modern")
+    (version "20220506.858")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emacs-jp/replace-colorthemes.git")
+                    (commit "74ad69bbca6fcfff3c0960d888c7c9c1f9f3e2e8")))
+              (sha256
+               (base32
+                "13ff4s372wsl5x13vh4vywhi6qcc54gybhp6rxl0r1l4wxidanwn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/emacs-jp/replace-colorthemes")
+    (synopsis "Over one hundred Emacs themes ported from color-theme")
+    (description "Over one hundred Emacs themes, including aalto-dark,
+aalto-light, aliceblue, andreas, arjen, beige-diff, beige-eshell,
+bharadwaj-slate, bharadwaj, billw, black-on-gray, blippblopp, blue-erc,
+blue-eshell, blue-gnus, blue-mood, blue-sea, calm-forest, charcoal-black,
+clarity, classic, cobalt, comidia, dark-blue, dark-blue2, dark-erc,
+dark-font-lock, dark-gnus, dark-green, dark-info, dark-laptop, deep-blue,
+desert, digital-ofs1, emacs-21, emacs-nw, euphoria, feng-shui, fischmeister,
+gnome, gnome2, goldenrod, gray1, gray30, greiner, gtk-ide, high-contrast,
+hober, infodoc, jb-simple, jedit-grey, jonadabian-slate, jonadabian, jsc-dark,
+jsc-light, jsc-light2, julie, katester, kingsajz, late-night, lawrence,
+ld-dark, lethe, marine, marquardt, matrix, midnight, mistyday, montz, oswald,
+parus, pierson, pok-wob, pok-wog, railscast, ramangalahy, raspopovic,
+renegade, resolve, retro-green, retro-orange, robin-hood, rotor, ryerson,
+salmon-diff, salmon-font-lock, scintilla, shaman, simple-1, sitaramv-nt,
+sitaramv-solaris, snow, snowish, standard-ediff, standard, subdued,
+subtle-blue, subtle-hacker, taming-mr-arneson, taylor, tty-dark, vim-colors,
+whateveryouwant, wheat, word-perfect, xemacs, xp")
+    (license license:gpl3+)))
+
 (define-public emacs-autothemer
   (package
     (name "emacs-autothemer")