diff mbox series

[bug#66823,gnome-team,3/4] gnu: Add libcallaudio.

Message ID f9493f2261837aef5e144e5cc39dc3a1ca980589.1698597871.git.vivien@planete-kraus.eu
State New
Headers show
Series Add GNOME Calls | expand

Commit Message

Vivien Kraus Oct. 29, 2023, 4:36 p.m. UTC
* gnu/packages/telephony.scm (libcallaudio): New variable.

Change-Id: I41cfe14136858fe0b2a302a9ed8d624d44ad2a95
---
 gnu/packages/telephony.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Maxim Cournoyer Oct. 31, 2023, 2:02 p.m. UTC | #1
Hi,

Vivien Kraus <vivien@planete-kraus.eu> writes:

> * gnu/packages/telephony.scm (libcallaudio): New variable.
>
> Change-Id: I41cfe14136858fe0b2a302a9ed8d624d44ad2a95
> ---
>  gnu/packages/telephony.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
> index d99b10903e..ca004afc7f 100644
> --- a/gnu/packages/telephony.scm
> +++ b/gnu/packages/telephony.scm
> @@ -94,6 +94,7 @@ (define-module (gnu packages telephony)
>    #:use-module (guix git-download)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix build-system gnu)
> +  #:use-module (guix build-system meson)
>    #:use-module (guix build-system qt))
>  
>  (define-public phonesim
> @@ -1160,3 +1161,29 @@ (define-public sofia-sip
>  uses such as VoIP, IM, and many other real-time and person-to-person
>  communication services.")
>      (license license:lgpl2.1)))
> +
> +(define-public libcallaudio
> +  (package
> +    (name "libcallaudio")
> +    (version "0.1.9")
> +    (source (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://gitlab.com/mobian1/callaudiod/")
> +             (commit version)))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32
> +         "0qnllb28101c2ss1k3iwr04gljfyjqmbla5csj6vkq1y63aagr9s"))))
> +    (build-system meson-build-system)
> +    (inputs
> +     (list alsa-lib glib pulseaudio))

Nitpick: for less than 5 inputs, if they fit on the line, I prefer (and
'guix style' too, I think):

--8<---------------cut here---------------start------------->8---
(inputs (list one two ...))
--8<---------------cut here---------------end--------------->8---

on a single line.

> +    (native-inputs
> +     (list
> +      `(,glib "bin")          ;for gdbus-codegen
> +      pkg-config))
> +    (home-page "https://gitlab.com/mobian1/callaudiod")
> +    (synopsis "Library for audio routing during voice calls")
> +    (description "This package provides callaudiod, a daemon to route audio during phone calls,
> +and a library.")

I'd use @command{callaudiod}.

Otherwise LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index d99b10903e..ca004afc7f 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -94,6 +94,7 @@  (define-module (gnu packages telephony)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system qt))
 
 (define-public phonesim
@@ -1160,3 +1161,29 @@  (define-public sofia-sip
 uses such as VoIP, IM, and many other real-time and person-to-person
 communication services.")
     (license license:lgpl2.1)))
+
+(define-public libcallaudio
+  (package
+    (name "libcallaudio")
+    (version "0.1.9")
+    (source (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.com/mobian1/callaudiod/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0qnllb28101c2ss1k3iwr04gljfyjqmbla5csj6vkq1y63aagr9s"))))
+    (build-system meson-build-system)
+    (inputs
+     (list alsa-lib glib pulseaudio))
+    (native-inputs
+     (list
+      `(,glib "bin")          ;for gdbus-codegen
+      pkg-config))
+    (home-page "https://gitlab.com/mobian1/callaudiod")
+    (synopsis "Library for audio routing during voice calls")
+    (description "This package provides callaudiod, a daemon to route audio during phone calls,
+and a library.")
+    (license license:gpl3+)))