diff mbox series

[bug#66823,gnome-team,1/4] gnu: feedbackd: Update to 0.2.1.

Message ID 7e5753b721da18acbcc426569fddaee2d7ee5d09.1698597871.git.vivien@planete-kraus.eu
State New
Headers show
Series Add GNOME Calls | expand

Commit Message

Vivien Kraus Oct. 29, 2023, 4:32 p.m. UTC
The package now uses a “gmobile” submodule that should be included as-is.

* gnu/packages/gnome.scm (feedbackd): Update to 0.2.1.
[#:phases 'unpack-gmobile]: New phase.

Change-Id: I06521c1673efb6aea1d163410fdf3d0206b57d8a
---
 gnu/packages/gnome.scm | 21 +++++++++++++++++++--
 1 file changed, 19 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler Oct. 29, 2023, 5:10 p.m. UTC | #1
Am Sonntag, dem 29.10.2023 um 17:32 +0100 schrieb Vivien Kraus:
> The package now uses a “gmobile” submodule that should be included
> as-is.
> 
> * gnu/packages/gnome.scm (feedbackd): Update to 0.2.1.
> [#:phases 'unpack-gmobile]: New phase.
Should be: [#:phases]: Add ‘unpack-gmobile’.  You might want to look
into building this with an already installed gmobile; meson ought to
support that use case.

> Change-Id: I06521c1673efb6aea1d163410fdf3d0206b57d8a
> ---
>  gnu/packages/gnome.scm | 21 +++++++++++++++++++--
>  1 file changed, 19 insertions(+), 2 deletions(-)
> 
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index a86ddc34b3..8092715795 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -12918,7 +12918,7 @@ (define-public jsonrpc-glib
>  (define-public feedbackd
>    (package
>      (name "feedbackd")
> -    (version "0.0.0+git20200527")
> +    (version "0.2.1")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -12927,8 +12927,25 @@ (define-public feedbackd
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -               
> "1wbkzxnqjydfgjvp7vz4ghczcz740zcb1yn90cb6gb5md4n6qx2y"))))
> +               
> "1acwpb8cgzyvzriphrb42k3d7njwcn88j66i5wz75yx2sbfaf93q"))))
>      (build-system meson-build-system)
> +    (arguments
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'unpack-gmobile
> +            (lambda _
> +              (copy-recursively
> +               #$(origin
> +                   (method git-fetch)
> +                   (uri (git-reference
> +                         (url
> "https://gitlab.gnome.org/guidog/gmobile")
> +                         (commit
> "d483537aee4778b114ce5d50c4c8a9f8d58337ed")))
> +                   (file-name (git-file-name "gmobile" version))
> +                   (sha256
> +                    (base32
> +                    
> "1789sdj4rkj1hh2r3jp45jn2df4vf2mqgk1jbc3ccrv39z0b9f4w")))
> +               "subprojects/gmobile"))))))
>      (native-inputs
>       (list `(,glib "bin") gobject-introspection pkg-config vala))
>      (inputs

Cheers
Maxim Cournoyer Oct. 31, 2023, 1:54 p.m. UTC | #2
Hello,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Sonntag, dem 29.10.2023 um 17:32 +0100 schrieb Vivien Kraus:
>> The package now uses a “gmobile” submodule that should be included
>> as-is.
>> 
>> * gnu/packages/gnome.scm (feedbackd): Update to 0.2.1.
>> [#:phases 'unpack-gmobile]: New phase.
> Should be: [#:phases]: Add ‘unpack-gmobile’.  You might want to look
> into building this with an already installed gmobile; meson ought to
> support that use case.

+1, or at least...

>> Change-Id: I06521c1673efb6aea1d163410fdf3d0206b57d8a
>> ---
>>  gnu/packages/gnome.scm | 21 +++++++++++++++++++--
>>  1 file changed, 19 insertions(+), 2 deletions(-)
>> 
>> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> index a86ddc34b3..8092715795 100644
>> --- a/gnu/packages/gnome.scm
>> +++ b/gnu/packages/gnome.scm
>> @@ -12918,7 +12918,7 @@ (define-public jsonrpc-glib
>>  (define-public feedbackd
>>    (package
>>      (name "feedbackd")
>> -    (version "0.0.0+git20200527")
>> +    (version "0.2.1")
>>      (source (origin
>>                (method git-fetch)
>>                (uri (git-reference
>> @@ -12927,8 +12927,25 @@ (define-public feedbackd
>>                (file-name (git-file-name name version))
>>                (sha256
>>                 (base32
>> -               
>> "1wbkzxnqjydfgjvp7vz4ghczcz740zcb1yn90cb6gb5md4n6qx2y"))))
>> +               
>> "1acwpb8cgzyvzriphrb42k3d7njwcn88j66i5wz75yx2sbfaf93q"))))
>>      (build-system meson-build-system)
>> +    (arguments
>> +     (list
>> +      #:phases
>> +      #~(modify-phases %standard-phases
>> +          (add-after 'unpack 'unpack-gmobile

... a comment here explaining why we can't simply use gmobile as a
library (build system limitation?  link to upstream issue?) is needed.

Otherwise it LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a86ddc34b3..8092715795 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12918,7 +12918,7 @@  (define-public jsonrpc-glib
 (define-public feedbackd
   (package
     (name "feedbackd")
-    (version "0.0.0+git20200527")
+    (version "0.2.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -12927,8 +12927,25 @@  (define-public feedbackd
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1wbkzxnqjydfgjvp7vz4ghczcz740zcb1yn90cb6gb5md4n6qx2y"))))
+                "1acwpb8cgzyvzriphrb42k3d7njwcn88j66i5wz75yx2sbfaf93q"))))
     (build-system meson-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'unpack-gmobile
+            (lambda _
+              (copy-recursively
+               #$(origin
+                   (method git-fetch)
+                   (uri (git-reference
+                         (url "https://gitlab.gnome.org/guidog/gmobile")
+                         (commit "d483537aee4778b114ce5d50c4c8a9f8d58337ed")))
+                   (file-name (git-file-name "gmobile" version))
+                   (sha256
+                    (base32
+                     "1789sdj4rkj1hh2r3jp45jn2df4vf2mqgk1jbc3ccrv39z0b9f4w")))
+               "subprojects/gmobile"))))))
     (native-inputs
      (list `(,glib "bin") gobject-introspection pkg-config vala))
     (inputs