diff mbox series

[bug#66037,2/3] gnu: osm2pgsql: Update to 1.9.2.

Message ID f8c036deb996e7c97a9f4d75cb6e8473469c6e51.1694898378.git.hendursaga@aol.com
State New
Headers show
Series Update libosmium and dependents | expand

Commit Message

Hendursaga Sept. 16, 2023, 9:21 p.m. UTC
* gnu/packages/geo.scm (osm2pgsql): Update to 1.9.2.
[arguments]: Use G-expressions.
<#:configure-flags>: Ensure compilation with LuaJIT, PROJ API version 6.
[inputs]: Replace lua with luajit. Add potrace, nlohmann-json.
[native-inputs]: Add pandoc, python-argparse-manpage, for building
documentation. Remove python-psycopg2, as it is only used for tests, and
testing has been disabled.
[home-page]: Update URL.
---
 gnu/packages/geo.scm | 72 +++++++++++++++++++++++---------------------
 1 file changed, 37 insertions(+), 35 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 3364fe6583..45d8f8945e 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1596,43 +1596,45 @@  (define-public osmium-tool
 (define-public osm2pgsql
   (package
     (name "osm2pgsql")
-    (version "1.8.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/openstreetmap/osm2pgsql")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0ssz7ny4wx8dzl3027p37xc5h7m1aj6bzxzdc6g8fbp7q57ykvxz"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; Remove bundled libraries.
-        '(delete-file-recursively "contrib"))))
+    (version "1.9.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/openstreetmap/osm2pgsql")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "198qcgl42pb8lk1bn41ncp8hc9gcg9k2p0ny42vak019w5l6jcj7"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Remove bundled libraries.
+               '(delete-file-recursively "contrib"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f; tests fail because we need to setup a database
-       #:configure-flags
-       (list "-DEXTERNAL_LIBOSMIUM=ON"
-             "-DEXTERNAL_PROTOZERO=ON"
-             "-DEXTERNAL_FMT=ON")))
-    (inputs
-     (list boost
-           bzip2
-           expat
-           fmt-8
-           libosmium
-           lua
-           postgresql
-           proj
-           protozero
-           zlib))
-    (native-inputs
-     (list python python-psycopg2))
-    (home-page "https://github.com/openstreetmap/osm2pgsql")
-    (synopsis "OSM data importer to postgresql")
-    (description "Osm2pgsql is a tool for loading OpenStreetMap data into a
+     (list #:tests? #f ;tests fail because we need to setup a database
+           #:configure-flags #~(list "-DUSE_PROJ_LIB=6" ;use API version 6
+                                     "-DWITH_LUAJIT=ON"
+                                     "-DEXTERNAL_LIBOSMIUM=ON"
+                                     "-DEXTERNAL_PROTOZERO=ON"
+                                     "-DEXTERNAL_FMT=ON")))
+    (inputs (list boost
+                  bzip2
+                  expat
+                  fmt-8
+                  libosmium
+                  luajit
+                  nlohmann-json
+                  postgresql
+                  potrace
+                  proj
+                  protozero
+                  zlib))
+    (native-inputs (list pandoc python python-argparse-manpage))
+    (home-page "https://osm2pgsql.org/")
+    (synopsis "OSM data importer to PostgreSQL")
+    (description
+     "Osm2pgsql is a tool for loading OpenStreetMap data into a
 PostgreSQL / PostGIS database suitable for applications like rendering into a
 map, geocoding with Nominatim, or general analysis.")
     (license license:gpl2+)))