diff mbox series

[bug#66037,1/3] gnu: libosmium: Update to 2.19.0.

Message ID f85dedc376e37da64d4cdfd9ead82001d257b30b.1694898378.git.hendursaga@aol.com
State New
Headers show
Series Update libosmium and dependents | expand

Commit Message

Hendursaga Sept. 16, 2023, 9:21 p.m. UTC
* gnu/packages/geo.scm (libosmium): Update to 2.19.0.
[inputs]: Replace proj with proj.4.
[native-inputs]: Add graphviz, to build documentation.
---
 gnu/packages/geo.scm | 48 +++++++++++++++++++++-----------------------
 1 file changed, 23 insertions(+), 25 deletions(-)

Comments

Bruno Victal Sept. 16, 2023, 9:34 p.m. UTC | #1
Hi Hendursaga,

On 2023-09-16 22:21, Hendursaga via Guix-patches via wrote:
> +    (native-inputs (list doxygen graphviz))

Perhaps you could use graphviz-minimal instead?
Guillaume Le Vaillant Sept. 21, 2023, 3:39 p.m. UTC | #2
Patches applied as 84442d04235a615984667363c0f9b6b91d1ed0bf and
following.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d702046865..3364fe6583 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -89,6 +89,7 @@  (define-module (gnu packages geo)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages gps)
   #:use-module (gnu packages graphics)
+  #:use-module (gnu packages graphviz)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages haskell-apps)
   #:use-module (gnu packages haskell-xyz)
@@ -1535,34 +1536,31 @@  (define-public python-metpy
 (define-public libosmium
   (package
     (name "libosmium")
-    (version "2.18.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/osmcode/libosmium")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0fh57mpii1ksacwfx5rz213j896aklib53jbybld2i517q2mmxr0"))))
+    (version "2.19.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/osmcode/libosmium")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d69xzd29hk846g049y2g668mr8kaf05f6a26s3qn6az062hxfa7"))))
     (build-system cmake-build-system)
-    (propagated-inputs
-     (list boost
-           bzip2
-           expat
-           gdal
-           geos
-           lz4
-           proj
-           protozero
-           sparsehash
-           utfcpp
-           zlib))
-    (native-inputs
-     (list doxygen))
+    (propagated-inputs (list boost
+                             bzip2
+                             expat
+                             gdal
+                             geos
+                             lz4
+                             proj.4
+                             protozero
+                             zlib))
+    (native-inputs (list doxygen graphviz))
     (home-page "https://osmcode.org/libosmium/")
     (synopsis "C++ library for working with OpenStreetMap data")
-    (description "Libosmium is a fast and flexible C++ library for working with
+    (description
+     "Libosmium is a fast and flexible C++ library for working with
 OpenStreetMap data.")
     (license license:boost1.0)))