diff mbox series

[bug#71145,1/3] gnu: ocaml-sedlex: Use G-Expressions.

Message ID f878a9b8fd36e25a16361f30aba822e54768fd2b.1716464340.git.jean@foundation.xyz
State New
Headers show
Series gnu: ocaml-sedlex: Update to 3.2. | expand

Commit Message

Jean-Pierre De Jesus DIAZ May 23, 2024, 11:47 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-sedlex): Use G-expressions.

Change-Id: I1dd8b9e1cefef90ff4cdcc592f5ad3d735a5081b
---
 gnu/packages/ocaml.scm | 40 +++++++++++++++++++---------------------
 1 file changed, 19 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ef092d8e41..2100227adf 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3783,27 +3783,25 @@  (define-public ocaml-sedlex
                 "1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f                      ; no tests
-       #:package "sedlex"
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'copy-resources
-           (lambda* (#:key inputs #:allow-other-keys)
-             (with-directory-excursion "src/generator/data"
-               ;; Newer versions of dune emit an error if files it wants to
-               ;; build already exist. Delete the dune file so dune doesn't
-               ;; complain.
-               (delete-file "dune")
-               (for-each
-                (lambda (file)
-                  (copy-file (assoc-ref inputs file) file))
-                '("DerivedCoreProperties.txt" "DerivedGeneralCategory.txt"
-                  "PropList.txt")))
-             #t))
-         (add-before 'build 'chmod
-           (lambda _
-             (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*"))
-             #t)))))
+     (list #:tests? #f                      ; no tests
+           #:package "sedlex"
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'build 'copy-resources
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (with-directory-excursion "src/generator/data"
+                     ;; Newer versions of dune emit an error if files it wants to
+                     ;; build already exist. Delete the dune file so dune doesn't
+                     ;; complain.
+                     (delete-file "dune")
+                     (for-each
+                      (lambda (file)
+                        (copy-file (assoc-ref inputs file) file))
+                      '("DerivedCoreProperties.txt" "DerivedGeneralCategory.txt"
+                        "PropList.txt")))))
+               (add-before 'build 'chmod
+                 (lambda _
+                   (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*")))))))
     (propagated-inputs
      (list ocaml-gen ocaml-ppxlib ocaml-uchar))
     ;; These three files are needed by src/generator/data/dune, but would be