diff mbox series

[bug#71145,3/3] gnu: ocaml-sedlex: Update to 3.2.

Message ID e0be8f3d885ca4bf356532091ee8c4514a1d1436.1716464340.git.jean@foundation.xyz
State New
Headers show
Series gnu: ocaml-sedlex: Update to 3.2. | expand

Commit Message

Jean-Pierre De Jesus DIAZ May 23, 2024, 11:47 a.m. UTC
* gnu/packages/haxe.scm (ocaml-sedlex): Update to 3.2.
(ocaml-sedlex-2): New variable.
(ocaml-piqilib) <propagated-inputs>: Replace ocaml-sedlex by ocaml-sedlex-2.
* gnu/packages/ocaml.scm (haxe) <inputs>: Replace ocaml-sedlex by ocaml-sedlex-2.

Change-Id: I0ae3609f8db22589d8fdd110d1b7b92f6fead15d
---
 gnu/packages/haxe.scm  |  2 +-
 gnu/packages/ocaml.scm | 28 ++++++++++++++++++++++++----
 2 files changed, 25 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index c7af07325f..f1cdc8732f 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -177,7 +177,7 @@  (define-public haxe
                   ocaml-extlib
                   ocaml-luv
                   ocaml-ptmap
-                  ocaml-sedlex
+                  ocaml-sedlex-2
                   ocaml-sha
                   ocaml-xml-light
                   pcre2
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 10b98ca758..c96b374a99 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3772,7 +3772,7 @@  (define-public ocaml-gen
 (define-public ocaml-sedlex
   (package
     (name "ocaml-sedlex")
-    (version "2.6")
+    (version "3.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3781,10 +3781,10 @@  (define-public ocaml-sedlex
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
+                "1vzsmp8mvx9vrgjr5chsk2p2s5ii08c9kizw9ilx78jj30nzamz5"))))
     (build-system dune-build-system)
     (arguments
-     (list #:tests? #f                      ; no tests
+     (list ;#:tests? #f                      ; no tests
            #:package "sedlex"
            #:phases
            #~(modify-phases %standard-phases
@@ -3807,6 +3807,7 @@  (define-public ocaml-sedlex
                (add-before 'build 'chmod
                  (lambda _
                    (for-each (lambda (file) (chmod file #o644)) (find-files "." ".*")))))))
+    (native-inputs (list ocaml-ppx-expect))
     (propagated-inputs
      (list ocaml-gen ocaml-ppxlib ocaml-uchar))
     (inputs
@@ -3816,6 +3817,25 @@  (define-public ocaml-sedlex
     (description "Lexer generator for Unicode and OCaml.")
     (license license:expat)))
 
+(define-public ocaml-sedlex-2
+  (package
+    (inherit ocaml-sedlex)
+    (name "ocaml-sedlex")
+    (version "2.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ocaml-community/sedlex")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1z8mmk1idh9hjhh2b9rp5b1h8kmzcxhagqkw0pvxn6ykx1brskq1"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments ocaml-sedlex)
+       ((#:tests? _ #t) #f)))               ; no tests
+    (native-inputs '())))
+
 (define-public ocaml-uchar
   (package
     (name "ocaml-uchar")
@@ -5218,7 +5238,7 @@  (define-public ocaml-piqilib
      (list which))
     (propagated-inputs
      `(("ocaml-xmlm" ,ocaml-xmlm)
-       ("ocaml-sedlex" ,ocaml-sedlex)
+       ("ocaml-sedlex" ,ocaml-sedlex-2)
        ("ocaml-easy-format" ,ocaml-easy-format)
        ("ocaml-base64" ,ocaml-base64)))
     (home-page "https://piqi.org")