diff mbox series

[bug#59322,v2,2/4] gnu: chez-scheme-for-racket: Support riscv64.

Message ID f77badf116d9ea9a0ebad18fe8819b45492501bc.1668730588.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: racket: Update to 8.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Philip McGrath Nov. 18, 2022, 12:45 a.m. UTC
Use the new native backend instead of "portable bytecode".

* gnu/packages/chez.scm (target-chez-arch): Support riscv64-linux-gnu.
(%chez-features-table): Likewise.
---
 gnu/packages/chez.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 7025a71b94..0d22e2e20f 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -104,7 +104,7 @@  (define* (target-chez-arch #:optional (system
    ((target-ppc32? system)
     "ppc32")
    ((target-riscv64? system)
-    #f)
+    "rv64")
    (else
     #f)))
 
@@ -170,6 +170,7 @@  (define %chez-features-table
      ("a6" threads bootstrap-bootfiles)
      ("arm32" bootstrap-bootfiles)
      ("arm64" . #f)
+     ("rv64" . #f)
      ("ppc32" threads))
     ;; Hurd
     ("gnu"