diff mbox series

[bug#59322,v2,4/4] etc: teams: Add chez.scm to Racket team's scope.

Message ID 3a1f02544e018bd1164b8d867c8e672bc751128c.1668730588.git.philip@philipmcgrath.com
State New
Headers show
Series gnu: racket: Update to 8.7. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Philip McGrath Nov. 18, 2022, 12:45 a.m. UTC
Racket's variant of Chez Scheme is defined in that file.

* etc/teams.scm.in (racket)[#:scope]: Add gnu/packages/chez.scm.
---
 etc/teams.scm.in | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Liliana Marie Prikler Nov. 18, 2022, 7:01 a.m. UTC | #1
Am Donnerstag, dem 17.11.2022 um 19:45 -0500 schrieb Philip McGrath:
> Racket's variant of Chez Scheme is defined in that file.
> 
> * etc/teams.scm.in (racket)[#:scope]: Add gnu/packages/chez.scm.
> ---
>  etc/teams.scm.in | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/etc/teams.scm.in b/etc/teams.scm.in
> index c458b14e3b..f744204017 100644
> --- a/etc/teams.scm.in
> +++ b/etc/teams.scm.in
> @@ -393,7 +393,8 @@ (define-team racket
>          "The Racket language and Racket-based languages, Racket
> packages,
>  Racket's variant of Chez Scheme, and development of a Racket build
> system and
>  importer."
> -        #:scope (list "gnu/packages/racket.scm")))
> +        #:scope (list "gnu/packages/chez.scm"
> +                      "gnu/packages/racket.scm")))
I'm not sure whether this accurately captures the intent of teams. 
Yes, chez-scheme is required in Racket's bootstrap, but the only
"legal" changes to Racket's variant also affect racket.scm.  On the
other hand, the Racket team would weigh in on changes that only affect
the Chez side, which imho is unwarranted.

Cheers
Simon Tournier Nov. 18, 2022, 8:26 a.m. UTC | #2
Hi,

On Fri, 18 Nov 2022 at 08:01, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:

>> -        #:scope (list "gnu/packages/racket.scm")))
>> +        #:scope (list "gnu/packages/chez.scm"
>> +                      "gnu/packages/racket.scm")))
>
> I'm not sure whether this accurately captures the intent of teams. 
> Yes, chez-scheme is required in Racket's bootstrap, but the only
> "legal" changes to Racket's variant also affect racket.scm.  On the
> other hand, the Racket team would weigh in on changes that only affect
> the Chez side, which imho is unwarranted.

Why not?  Considering the only person part of the Racket team is Philip,
the false-positive seems acceptable, no?

BTW, Liliana, since you are often reviewing these patches, why not also
add you as part of the Racket team?


Cheers,
simon
Liliana Marie Prikler Nov. 18, 2022, 7:23 p.m. UTC | #3
Am Freitag, dem 18.11.2022 um 09:26 +0100 schrieb zimoun:
> Hi,
> 
> On Fri, 18 Nov 2022 at 08:01, Liliana Marie Prikler
> <liliana.prikler@ist.tugraz.at> wrote:
> 
> > > -        #:scope (list "gnu/packages/racket.scm")))
> > > +        #:scope (list "gnu/packages/chez.scm"
> > > +                      "gnu/packages/racket.scm")))
> > 
> > I'm not sure whether this accurately captures the intent of teams. 
> > Yes, chez-scheme is required in Racket's bootstrap, but the only
> > "legal" changes to Racket's variant also affect racket.scm.  On the
> > other hand, the Racket team would weigh in on changes that only
> > affect the Chez side, which imho is unwarranted.
> 
> Why not?  Considering the only person part of the Racket team is
> Philip, the false-positive seems acceptable, no?
Given that folks tune out the main mailing list 

> BTW, Liliana, since you are often reviewing these patches, why not
> also add you as part of the Racket team?
To be frank, I only review them with respect to Guix coding guidelines.
I have no idea how Racket itself works – if I did, I would already have
fixed some annoyances with its packaging – and I fear that despite all
my efforts Philip might be the only one who truly understands what's
going on.

Cheers
Philip McGrath Nov. 18, 2022, 7:33 p.m. UTC | #4
Hi,

On Friday, November 18, 2022 3:26:27 AM EST zimoun wrote:
> Hi,
> 
> On Fri, 18 Nov 2022 at 08:01, Liliana Marie Prikler 
<liliana.prikler@ist.tugraz.at> wrote:
> >> -        #:scope (list "gnu/packages/racket.scm")))
> >> +        #:scope (list "gnu/packages/chez.scm"
> >> +                      "gnu/packages/racket.scm")))
> > 
> > I'm not sure whether this accurately captures the intent of teams.
> > Yes, chez-scheme is required in Racket's bootstrap, but the only
> > "legal" changes to Racket's variant also affect racket.scm.  On the
> > other hand, the Racket team would weigh in on changes that only affect
> > the Chez side, which imho is unwarranted.
> 
> Why not?  Considering the only person part of the Racket team is Philip,
> the false-positive seems acceptable, no?
> 

I don't have a strong view: feel free to just drop this patch for now if you 
feel it needs more discussion but the others are ready to merge.

Since the chez-scheme-for-racket package inherits from the chez-scheme 
package, any change to the chez-scheme package will affect racket, racket-
minimal, and racket-vm-cs.

I could certainly imagine having a Chez team that doesn't necessarily care 
about Racket. Likewise, in both languages, I imagine there could be people 
interested in packages that use the language but who wouldn't necessarily be 
interested in the packaging of the compilers and run-time systems themselves. 
But, since no one else has signed on and I've made the majority of changes to 
both files in the last two years, designing a more fine-grained team structure 
seemed premature.

I guess I've also thought of teams as less "would way in on" changes and more 
as "would like to be CC'ed about" them. I'd rather get a little more email 
than miss relevant changes (even though I can't keep up with the whole patches 
mailing list).

-Philip
Liliana Marie Prikler Nov. 19, 2022, 7:54 a.m. UTC | #5
Am Freitag, dem 18.11.2022 um 14:33 -0500 schrieb Philip McGrath:
> I could certainly imagine having a Chez team that doesn't necessarily
> care about Racket. Likewise, in both languages, I imagine there could
> be people  interested in packages that use the language but who
> wouldn't necessarily be interested in the packaging of the compilers
> and run-time systems themselves. 
> But, since no one else has signed on and I've made the majority of
> changes to both files in the last two years, designing a more fine-
> grained team structure seemed premature.
I can see where you're coming from, but my personal opinion is that
merging these "two" teams now might discourage us from splitting them
later.  In my humble opinion, adding a chez team with you as sole
member wouldn't hurt for the time being.

Cheers
Philip McGrath Nov. 19, 2022, 11:52 p.m. UTC | #6
On Saturday, November 19, 2022 2:54:55 AM EST Liliana Marie Prikler wrote:
> Am Freitag, dem 18.11.2022 um 14:33 -0500 schrieb Philip McGrath:
> > I could certainly imagine having a Chez team that doesn't necessarily
> > care about Racket. Likewise, in both languages, I imagine there could
> > be people  interested in packages that use the language but who
> > wouldn't necessarily be interested in the packaging of the compilers
> > and run-time systems themselves.
> > But, since no one else has signed on and I've made the majority of
> > changes to both files in the last two years, designing a more fine-
> > grained team structure seemed premature.
> 
> I can see where you're coming from, but my personal opinion is that
> merging these "two" teams now might discourage us from splitting them
> later.  In my humble opinion, adding a chez team with you as sole
> member wouldn't hurt for the time being.
> 

Is there a requirement that teams' scopes be disjoint? In other words, is 
there any reason "gnu/packages/chez.scm" shouldn't be in scope for both the 
racket team and a potential chez team?

Another factor that might be relevant: Matthew Flatt tells me he is actively 
working with the Chez Scheme maintainers to merge the two branches. I'm not 
involved in these discussions myself: my understanding is that details are 
still being worked out, and I don't know what the time frame will be, but from 
what I'm told it's gone from "not in the foreseeable future" to "will happen".

(There's no plan to synchronize the release cycles, and Racket will continue 
to rely on unstable Chez system functions and to have the Chez version form 
part of its ABI, so we will likely continue to have a chez-scheme-for-racket 
package, but it should be a much simpler transformation to use a particular 
pre-release version.)

After the merge, we should be able to bootstrap upstream Chez Scheme via 
Racket as we currently do with chez-scheme-for-racket, at which changes to 
Racket will also potentially impact Chez Scheme.

Personally, if there were more people involved, I'd organize it as teams for 
chez-and-racket-bootstrap, chez, and racket, as I'd initially tried to do in 
https://issues.guix.gnu.org/53878, but that especially seems like too much if 
they all consist of the same one person. If you still want a chez team, 
though, I guess I'm ok with that.

I just hope this need not delay the update to 8.7 any further.

-Philip
Liliana Marie Prikler Nov. 20, 2022, 1:49 a.m. UTC | #7
Am Samstag, dem 19.11.2022 um 18:52 -0500 schrieb Philip McGrath:
> [...]
> Is there a requirement that teams' scopes be disjoint? In other
> words, is there any reason "gnu/packages/chez.scm" shouldn't be in
> scope for both the racket team and a potential chez team?
Not necessarily, but I think exceptions should be well argued.  For
instance, it would make sense for a change in Emacs' build system to
reach both Emacs and core maintainers.  In practice however, core does
not have any build system in their scope, which strengthens my argument
for disjoint groups.

> Another factor that might be relevant: Matthew Flatt tells me he is
> actively working with the Chez Scheme maintainers to merge the two
> branches.  I'm not involved in these discussions myself: my
> understanding is that details are still being worked out, and I don't
> know what the time frame will be, but from what I'm told it's gone
> from "not in the foreseeable future" to "will happen".
> 
> (There's no plan to synchronize the release cycles, and Racket will
> continue to rely on unstable Chez system functions and to have the
> Chez version form part of its ABI, so we will likely continue to have
> a chez-scheme-for-racket package, but it should be a much simpler
> transformation to use a particular pre-release version.)
Depending on how well that goes, that'd be one headache less.  I'll be
cautiously optimistic and hope that Racket won't do another Zuo and
publish a subtree without release tags.

> After the merge, we should be able to bootstrap upstream Chez Scheme
> via Racket as we currently do with chez-scheme-for-racket, at which
> changes to Racket will also potentially impact Chez Scheme.
> 
> Personally, if there were more people involved, I'd organize it as
> teams for chez-and-racket-bootstrap, chez, and racket, as I'd
> initially tried to do in https://issues.guix.gnu.org/53878, but that
> especially seems like too much if they all consist of the same one
> person. If you still want a chez team, though, I guess I'm ok with
> that.
Three teams for two packages is definitely overkill.  I'd make it
either one or two, with the caveat that both of them being the same
should rest on a sound argument rather than a vague one.  If chez and
racket were interchangeable like different Common Lisp interpretations,
that'd be such an argument, or if there was a shared community not just
by virtue of bootstrapping.

> I just hope this need not delay the update to 8.7 any further.
Well, since CI already built everything and 1-3 LGTM, I went ahead and
pushed it, so you don't need to worry.

Cheers
Simon Tournier Nov. 21, 2022, 4:50 p.m. UTC | #8
Hi,

On Sat, 19 Nov 2022 at 08:54, Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

> I can see where you're coming from, but my personal opinion is that
> merging these "two" teams now might discourage us from splitting them
> later.  In my humble opinion, adding a chez team with you as sole
> member wouldn't hurt for the time being.

Philip, could you send a patch for creating these two teams?

Cheers,
simon
Ludovic Courtès Nov. 23, 2022, 6:44 p.m. UTC | #9
Hi Philip & all,

Philip McGrath <philip@philipmcgrath.com> skribis:

> On Saturday, November 19, 2022 2:54:55 AM EST Liliana Marie Prikler wrote:
>> Am Freitag, dem 18.11.2022 um 14:33 -0500 schrieb Philip McGrath:
>> > I could certainly imagine having a Chez team that doesn't necessarily
>> > care about Racket. Likewise, in both languages, I imagine there could
>> > be people  interested in packages that use the language but who
>> > wouldn't necessarily be interested in the packaging of the compilers
>> > and run-time systems themselves.
>> > But, since no one else has signed on and I've made the majority of
>> > changes to both files in the last two years, designing a more fine-
>> > grained team structure seemed premature.
>> 
>> I can see where you're coming from, but my personal opinion is that
>> merging these "two" teams now might discourage us from splitting them
>> later.  In my humble opinion, adding a chez team with you as sole
>> member wouldn't hurt for the time being.
>> 
>
> Is there a requirement that teams' scopes be disjoint? In other words, is 
> there any reason "gnu/packages/chez.scm" shouldn't be in scope for both the 
> racket team and a potential chez team?

No.  To me, the goal of teams is to have groups of people one can talk
to when touching a particular part of the code base.  In that sense,
your patch is a welcome improvement over the status quo; in fact, it
just formalizes what has been a de-facto situation: you’re our Racket
and Chez expert.  And even a Racket ambassador.  :-)

So I think we can go ahead with this patch and remain open to getting
more folks on board whenever an opportunity arises.

Thoughts?

Thanks,
Ludo’.
Ludovic Courtès Dec. 1, 2022, 9:08 p.m. UTC | #10
Hi,

Philip McGrath <philip@philipmcgrath.com> skribis:

> Racket's variant of Chez Scheme is defined in that file.
>
> * etc/teams.scm.in (racket)[#:scope]: Add gnu/packages/chez.scm.

I went ahead and applied it.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index c458b14e3b..f744204017 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -393,7 +393,8 @@  (define-team racket
         "The Racket language and Racket-based languages, Racket packages,
 Racket's variant of Chez Scheme, and development of a Racket build system and
 importer."
-        #:scope (list "gnu/packages/racket.scm")))
+        #:scope (list "gnu/packages/chez.scm"
+                      "gnu/packages/racket.scm")))
 
 
 (define-member (person "Thiago Jung Bauermann"