diff mbox series

[bug#49150,3/9] gnu: Add ocaml-menhir-sdk.

Message ID f733b976e1cf78b3d2a80eea904ab7fa5a2c6df4.1624269361.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocamlformat and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 21, 2021, 10:01 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
---
 gnu/packages/ocaml.scm | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Julien Lepiller June 27, 2021, 1:20 p.m. UTC | #1
Le Mon, 21 Jun 2021 12:01:53 +0200,
Xinglu Chen <public@yoctocell.xyz> a écrit :

> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
> ---
>  gnu/packages/ocaml.scm | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
> 
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 08406a206d..d7d3afd36c 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
>      (description "This package provides a runtime support library
> for parsers generated by Menhir.")))
>  
> +(define-public ocaml-menhir-sdk
> +  (package
> +    (inherit ocaml-menhir)
> +    (name "ocaml-menhir-sdk")
> +    (arguments
> +     '(#:package "menhirSdk"
> +       #:test-target "sdk"))
> +    (properties
> +     `((upstream-name . "menhirSdk")))
> +    (synopsis "Compile-time library for auxiliary tools related to
> Menhir")
> +    (description "This package provides a compile-time library for
> auxiliary +tools related to Menhir.")))
> +
>  (define-public ocaml-bigarray-compat
>    (package
>      (name "ocaml-bigarray-compat")

MenhirLib and MenhirSdk are both already part of the ocaml-menhir
package, so I don't think it is useful to add separate packages for
them. WDYT?
Xinglu Chen June 27, 2021, 1:37 p.m. UTC | #2
On Sun, Jun 27 2021, Julien Lepiller wrote:

> Le Mon, 21 Jun 2021 12:01:53 +0200,
> Xinglu Chen <public@yoctocell.xyz> a écrit :
>
>> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
>> ---
>>  gnu/packages/ocaml.scm | 13 +++++++++++++
>>  1 file changed, 13 insertions(+)
>> 
>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>> index 08406a206d..d7d3afd36c 100644
>> --- a/gnu/packages/ocaml.scm
>> +++ b/gnu/packages/ocaml.scm
>> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
>>      (description "This package provides a runtime support library
>> for parsers generated by Menhir.")))
>>  
>> +(define-public ocaml-menhir-sdk
>> +  (package
>> +    (inherit ocaml-menhir)
>> +    (name "ocaml-menhir-sdk")
>> +    (arguments
>> +     '(#:package "menhirSdk"
>> +       #:test-target "sdk"))
>> +    (properties
>> +     `((upstream-name . "menhirSdk")))
>> +    (synopsis "Compile-time library for auxiliary tools related to
>> Menhir")
>> +    (description "This package provides a compile-time library for
>> auxiliary +tools related to Menhir.")))
>> +
>>  (define-public ocaml-bigarray-compat
>>    (package
>>      (name "ocaml-bigarray-compat")
>
> MenhirLib and MenhirSdk are both already part of the ocaml-menhir
> package, so I don't think it is useful to add separate packages for
> them. WDYT?

Ah, then we can probably drop them, but they (Menhir, MenhirLib, and
MenhirSdk) are three separate packages on Opam, so i could also make
sense to restrict ‘ocaml-menhir’ to only the Menhir package.

WDYT?
Xinglu Chen Aug. 4, 2021, 8:23 a.m. UTC | #3
On Sun, Jun 27 2021, Xinglu Chen wrote:

> On Sun, Jun 27 2021, Julien Lepiller wrote:
>
>> Le Mon, 21 Jun 2021 12:01:53 +0200,
>> Xinglu Chen <public@yoctocell.xyz> a écrit :
>>
>>> * gnu/packages/ocaml.scm (ocaml-menhir-sdk): New variable.
>>> ---
>>>  gnu/packages/ocaml.scm | 13 +++++++++++++
>>>  1 file changed, 13 insertions(+)
>>> 
>>> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
>>> index 08406a206d..d7d3afd36c 100644
>>> --- a/gnu/packages/ocaml.scm
>>> +++ b/gnu/packages/ocaml.scm
>>> @@ -1069,6 +1069,19 @@ Knuth’s LR(1) parser construction technique.")
>>>      (description "This package provides a runtime support library
>>> for parsers generated by Menhir.")))
>>>  
>>> +(define-public ocaml-menhir-sdk
>>> +  (package
>>> +    (inherit ocaml-menhir)
>>> +    (name "ocaml-menhir-sdk")
>>> +    (arguments
>>> +     '(#:package "menhirSdk"
>>> +       #:test-target "sdk"))
>>> +    (properties
>>> +     `((upstream-name . "menhirSdk")))
>>> +    (synopsis "Compile-time library for auxiliary tools related to
>>> Menhir")
>>> +    (description "This package provides a compile-time library for
>>> auxiliary +tools related to Menhir.")))
>>> +
>>>  (define-public ocaml-bigarray-compat
>>>    (package
>>>      (name "ocaml-bigarray-compat")
>>
>> MenhirLib and MenhirSdk are both already part of the ocaml-menhir
>> package, so I don't think it is useful to add separate packages for
>> them. WDYT?
>
> Ah, then we can probably drop them, but they (Menhir, MenhirLib, and
> MenhirSdk) are three separate packages on Opam, so i could also make
> sense to restrict ‘ocaml-menhir’ to only the Menhir package.
>
> WDYT?

Ping!  :)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 08406a206d..d7d3afd36c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1069,6 +1069,19 @@  Knuth’s LR(1) parser construction technique.")
     (description "This package provides a runtime support library for parsers
 generated by Menhir.")))
 
+(define-public ocaml-menhir-sdk
+  (package
+    (inherit ocaml-menhir)
+    (name "ocaml-menhir-sdk")
+    (arguments
+     '(#:package "menhirSdk"
+       #:test-target "sdk"))
+    (properties
+     `((upstream-name . "menhirSdk")))
+    (synopsis "Compile-time library for auxiliary tools related to Menhir")
+    (description "This package provides a compile-time library for auxiliary
+tools related to Menhir.")))
+
 (define-public ocaml-bigarray-compat
   (package
     (name "ocaml-bigarray-compat")