diff mbox series

[bug#49150,8/9] gnu: Add ocaml-dune-build-info.

Message ID 9168948c67bdf6830b4075d0ada0526f03e4168f.1624269361.git.public@yoctocell.xyz
State Accepted
Headers show
Series Add ocamlformat and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen June 21, 2021, 10:02 a.m. UTC
* gnu/packages/ocaml.scm (ocaml-dune-build-info): New variable.
---
 gnu/packages/ocaml.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 94e5f23ec0..b78e3ab2fa 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7085,6 +7085,24 @@  representation.")
 that involve memoization and recursion.")
     (license license:lgpl2.0)))
 
+(define-public ocaml-dune-build-info
+  (package
+    (inherit dune)
+    (name "ocaml-dune-build-info")
+    (build-system dune-build-system)
+    (arguments
+     '(#:package "dune-build-info"
+       ;; No separate test suite from dune.
+       #:tests? #f))
+    (propagated-inputs
+     `(("ocaml-odoc" ,ocaml-odoc)))
+    (synopsis "Embed build informations inside executable")
+    (description "This package allows one to access information about how the
+executable was built, such as the version of the project at which it was built
+or the list of statically linked libraries with their versions.  It supports
+reporting the version from the version control system during development to
+get an precise reference of when the executable was built.")))
+
 (define-public ocaml-bigstringaf
   (package
     (name "ocaml-bigstringaf")