diff mbox series

[bug#51987,core-updates-frozen] gnu: ledger: Remove failing test output.

Message ID f6nBMBeLWxV8BA90ZdT42NLpOgLVbKcfozVlemi9jvFolsOQc_IHo_i5GwOKRibgQCiqvMMvL1IFmaqxk-zJnYVIr435fdNgWSxEL-z97YY=@protonmail.com
State Accepted
Headers show
Series [bug#51987,core-updates-frozen] gnu: ledger: Remove failing test output. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Nov. 20, 2021, 6:08 p.m. UTC
Hello,

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Saturday, November 20th, 2021 at 4:19 AM, Guillaume Le Vaillant wrote:

> Instead of adding a patch removing the file, wouldn't it be simpler to just add a phase
> calling '(delete-file "test/...")'?

That's a very good point, much easier! I've attached v2 of the patch (commit message also had a typo before) where I used a snippet to remove the file. I haven't written a snippet before but seemed like a clean and explicit way to do the source modification here.

Hope that's better!

John

Comments

Guillaume Le Vaillant Nov. 20, 2021, 6:26 p.m. UTC | #1
Patch pushed as c51667d52ed40b70cd15ff890141bff98f5e0d9a.
Thanks.
diff mbox series

Patch

From 49cfab2b6c52bd0be59f17f9bbcd669937beb2a6 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sat, 20 Nov 2021 13:02:25 -0500
Subject: [PATCH V2] gnu: ledger: Remove failing test output.

* gnu/packages/finance.scm (ledger)[source]: Add snippet to remove a failing test.
---
 gnu/packages/finance.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 354a2f2e0f..0c045b7bd3 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2021 ZmnSCPxj jxPCSnmZ <ZmnSCPxj@protonmail.com>
 ;;; Copyright © 2021 François J <francois-oss@avalenn.eu>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -304,7 +305,14 @@  (define-public ledger
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0x6jxwss3wwzbzlwmnwb8yzjk8f9wfawif4f1b74z2qg6hc4r7f6"))))
+        (base32 "0x6jxwss3wwzbzlwmnwb8yzjk8f9wfawif4f1b74z2qg6hc4r7f6"))
+       (snippet '(begin
+                   ;; Remove test that fails due to difference in
+                   ;; reported error message (missing leading "./" in the
+                   ;; file name); started some time after Guix commit
+                   ;; 727f05e1e285aa52f5a19ec923fdc2259859b4b1
+                   (delete-file "test/regress/BF3C1F82-2.test")
+                   #true))))
     (build-system cmake-build-system)
     (arguments
      `(#:modules (,@%cmake-build-system-modules
-- 
2.33.1