diff mbox series

[bug#69476,2/8] guix: Add xtensa-ath9k-elf platform.

Message ID f4ed9445b4b3229f4a67242678b5ca6454cc52d7.1709219325.git.jean@foundationdevices.com
State New
Headers show
Series guix: Add xtensa-ath9k-elf platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Feb. 29, 2024, 3:20 p.m. UTC
* Makefile.am (MODULES): Add guix/platforms/xtensa.scm.
* guix/platforms/xtensa.scm (xtensa-ath9k-elf): New variable.
* doc/guix.texi: Add xtensa-ath9k-elf documentation.

Change-Id: I51eef245142ed58613340c16d4bf7266e6bf6adb
---
 Makefile.am               |  1 +
 doc/guix.texi             |  6 ++++++
 guix/platforms/xtensa.scm | 28 ++++++++++++++++++++++++++++
 3 files changed, 35 insertions(+)
 create mode 100644 guix/platforms/xtensa.scm
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index cef972880c..df62c4e255 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -144,6 +144,7 @@  MODULES =					\
   guix/platforms/powerpc.scm                    \
   guix/platforms/riscv.scm                      \
   guix/platforms/x86.scm                        \
+  guix/platforms/xtensa.scm                     \
   guix/build-system.scm				\
   guix/build-system/agda.scm			\
   guix/build-system/android-ndk.scm		\
diff --git a/doc/guix.texi b/doc/guix.texi
index 7153c9e7a4..d3db1ee03d 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -16965,6 +16965,7 @@  Cross-Compilation
    - x86_64-linux-gnu
    - x86_64-linux-gnux32
    - x86_64-w64-mingw32
+   - xtensa-ath9k-elf
 @end example
 
 Targets are specified as GNU triplets (@pxref{Specifying Target
@@ -46763,6 +46764,11 @@  Supported Platforms
 C standard library.
 @end defvar
 
+@defvar xtensa-ath9k-elf
+Platform targeting Xtensa CPU used in the Qualcomm Atheros AR7010 and AR9271
+USB 802.11n @acronym{NICs, Network Interface Controllers}.
+@end defvar
+
 @node System Images
 @chapter Creating System Images
 
diff --git a/guix/platforms/xtensa.scm b/guix/platforms/xtensa.scm
new file mode 100644
index 0000000000..304e23ab1a
--- /dev/null
+++ b/guix/platforms/xtensa.scm
@@ -0,0 +1,28 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix platforms xtensa)
+  #:use-module (guix platform)
+  #:use-module (guix records)
+  #:export (xtensa-ath9k-elf))
+
+(define xtensa-ath9k-elf
+  (platform
+   (target "xtensa-ath9k-elf")
+   (system #f)
+   (glibc-dynamic-linker #f)))