diff mbox series

[bug#69476,5/8] gnu: ath9k-htc-firmware: Use xtensa-ath9k-elf.

Message ID 51b3861e69dc0ab0e52692448e9280a364a3397e.1709219325.git.jean@foundationdevices.com
State New
Headers show
Series guix: Add xtensa-ath9k-elf platform. | expand

Commit Message

Jean-Pierre De Jesus DIAZ Feb. 29, 2024, 3:20 p.m. UTC
* gnu/packages/firmware.scm (ath9k-htc-firmware): Use the
xtensa-ath9k-elf target for the cross toolchain.

Change-Id: Ic1a7c4088312290a86a508f371f4f0e784e301a5
---
 gnu/packages/cross-base.scm | 4 ++--
 gnu/packages/firmware.scm   | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 2d79e0acf6..93383089e5 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -118,8 +118,8 @@  (define* (cross-binutils* target #:key (binutils binutils))
                         ;; target libs, not native libs, so this is safe.
                         `(cons "--with-sysroot=/" ,flags)))))))
 
-    ;; For Xtensa, apply Qualcomm's patch.
-    (cross (cond ((string-prefix? "xtensa-" target)
+    ;; For xtensa-ath9k-elf, apply Qualcomm's patch.
+    (cross (cond ((string=? target "xtensa-ath9k-elf")
                   (package-with-patches binutils
                                         (search-patches
                                          "ath9k-htc-firmware-binutils.patch")))
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index da7835a95d..6993925387 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -121,7 +121,7 @@  (define-public ath9k-htc-firmware
              ;; 'configure' is a simple script that runs 'cmake' with
              ;; the right flags.
              (substitute* "configure"
-               (("^TARGET.*$") "TARGET=xtensa-elf\n")
+               (("^TARGET.*$") "TARGET=xtensa-ath9k-elf\n")
                (("^TOOLCHAIN=.*$")
                 (string-append "TOOLCHAIN="
                                (assoc-ref (or native-inputs inputs) "cross-gcc")
@@ -140,12 +140,12 @@  (define-public ath9k-htc-firmware
     ;; The firmware is cross-compiled using a "bare bones" compiler (no libc.)
     ;; Use our own tool chain for that.
     (native-inputs `(("cross-gcc" ,(cross-gcc
-                                    "xtensa-elf"
+                                    "xtensa-ath9k-elf"
                                     #:xbinutils (cross-binutils
-                                                 "xtensa-elf"
+                                                 "xtensa-ath9k-elf"
                                                  #:binutils binutils-2.33)))
                      ("cross-binutils" ,(cross-binutils
-                                         "xtensa-elf"
+                                         "xtensa-ath9k-elf"
                                          #:binutils binutils-2.33))
                      ("cmake" ,cmake-minimal)
                      ("perl" ,perl)))