diff mbox series

[bug#65037,v5,5/6] gnu: trezord: Update to 2.0.33.

Message ID f43f1a0798e90c9a0134be6376947d8f52ef0b92.1695829651.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,v5,1/6] gnu: Add python-construct-classes. | expand

Commit Message

Attila Lendvai Sept. 27, 2023, 3:47 p.m. UTC
* gnu/packages/finance.scm (trezord): Update version and hash, specify go-1.20
as the compiler.
---
 gnu/packages/finance.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 76096ab643..4e4f9c8dc2 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1663,7 +1663,7 @@  (define-public trezord-udev-rules
 (define-public trezord
   (package
     (name "trezord")
-    (version "2.0.31")
+    (version "2.0.33")
     (source
      (origin
        (method git-fetch)
@@ -1671,11 +1671,13 @@  (define-public trezord
              (url "https://github.com/trezor/trezord-go")
              (commit (string-append "v" version))))
        (sha256
-        (base32 "130nhk1pnr3xx9qkcij81mm3jxrl5zvvdqhvrgvrikqg3zlb6v5b"))
+        (base32 "0nnfh9qkb8ljajkxwrn3nn85zrsw10hp7c5i4zh60qgfyl0djppw"))
        (file-name (git-file-name name version))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/trezor/trezord-go"))
+     `(#:import-path "github.com/trezor/trezord-go"
+       ;; Requires go 1.18 or later: https://github.com/trezor/trezord-go/commit/f559ee5079679aeb5f897c65318d3310f78223ca
+       #:go ,go-1.20))
     (native-inputs
      `(("github.com/gorilla-csrf" ,go-github-com-gorilla-csrf)
        ("github.com/gorilla/handlers" ,go-github-com-gorilla-handlers)