diff mbox series

[bug#65037,v5,3/6] gnu: python-trezor-agent: Update to 0.14.7.

Message ID 961dcc5b438a22d38424df0e20817d1327c6b9c3.1695829651.git.attila@lendvai.name
State New
Headers show
Series [bug#65037,v5,1/6] gnu: Add python-construct-classes. | expand

Commit Message

Attila Lendvai Sept. 27, 2023, 3:47 p.m. UTC
* gnu/packages/finance.scm (python-trezor-agent) [native-inputs]: Add
python-bech32 and python-cryptography.
---
 gnu/packages/finance.scm | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3a196bd783..8194b660f3 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -923,7 +923,7 @@  (define-public python-trezor-agent
   ;; the toplevel app called trezor-agent.
   (package
     (name "python-trezor-agent")
-    (version "0.14.4")
+    (version "0.14.7")
     (source
      (origin
        (method git-fetch)
@@ -932,7 +932,7 @@  (define-public python-trezor-agent
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1ksv494xpga27ifrjyn1bkqaya5h769lqb9rx1ng0n4kvmnrqr3l"))))
+        (base32 "04dds5bbw73nk36zm8d02qw6qr92nrlcf8r1cq8ba96mzi34jbk0"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -960,8 +960,12 @@  (define-public python-trezor-agent
            python-semver
            python-unidecode
            python-wheel))
-    (native-inputs
-     (list gnupg python-mock python-pytest))
+    (native-inputs ; Only needed for running the tests
+     (list gnupg
+           python-bech32
+           python-cryptography
+           python-mock
+           python-pytest))
     (home-page "https://github.com/romanz/trezor-agent")
     (synopsis "Use hardware wallets as SSH and GPG agent")
     (description