diff mbox series

[bug#62262,v2,1/2] gnu: Add xpenguins.

Message ID f42ff8c87a91fabf3fe953e570f370a728e1067c.1706640937.git.code@greghogan.com
State Under Review
Delegated to: futurile
Headers show
Series Add xpenguins and xfishtank. | expand

Commit Message

Greg Hogan Jan. 30, 2024, 6:55 p.m. UTC
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xpenguins): New variable.

Change-Id: I6262092da4d51abaca1d6f01ec2e3f27baca7a01
---
 gnu/packages/toys.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index c058e70dac..6fdc931ae6 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Sarthak Shah <shahsarthakw@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -399,6 +400,39 @@  (define-public xsnow
 and various scenery elements.")
     (license license:gpl3+)))
 
+(define-public xpenguins
+  (package
+    (name "xpenguins")
+    (version "3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://ratrabbit.nl/downloads/xpenguins/xpenguins-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "03qwc7gf21d2ixkrxxwwgayj6f5fv1kg4b7ggx90j5269il63adm"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin"))))))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/software/xpenguins/index.html")
+    (synopsis "Let penguins take over your desktop!")
+    (description "@code{Xpenguins} is a vintage application for Unix systems,
+showing penguins running, flying, falling etc. on the desktop, using windows as
+run paths.")
+    (license license:gpl2+)))
+
 (define-public nyancat
   (package
     (name "nyancat")