diff mbox series

[bug#62262,v2,2/2] gnu: Add xfishtank.

Message ID 7acc286f1f6989627668cd4babfe1402f52d34f4.1706640937.git.code@greghogan.com
State Under Review
Delegated to: futurile
Headers show
Series Add xpenguins and xfishtank. | expand

Commit Message

Greg Hogan Jan. 30, 2024, 6:55 p.m. UTC
From: Sarthak Shah <shahsarthakw@gmail.com>

* gnu/packages/toys.scm (xfishtank): New variable.

Change-Id: I490fba2d9ded274266d6376adf67c39bf5c9744a
---
 gnu/packages/toys.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 6fdc931ae6..caefce0c68 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -433,6 +433,38 @@  (define-public xpenguins
 run paths.")
     (license license:gpl2+)))
 
+(define-public xfishtank
+  (package
+    (name "xfishtank")
+    (version "3.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+              "https://ratrabbit.nl/downloads/xfishtank/xfishtank-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "0jbx41kdpgm3nrnrvfy9znkipd8xq0jj5plavcsjkhkva8ybc0ax"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-install-path
+           (lambda _
+             ;; Install program to bin instead of games.
+             (substitute* "src/Makefile.in"
+               (("(gamesdir = \\$\\(exec_prefix\\)/)games" _ prefix)
+                (string-append prefix "bin"))))))))
+    (inputs
+     (list gtk+ libx11 libxpm libxt libxml2))
+    (native-inputs
+     (list pkg-config))
+    (home-page "https://www.ratrabbit.nl/ratrabbit/software/xfishtank/index.html")
+    (synopsis "Let fish swim over your desktop!")
+    (description "@code{Xfishtank} is a well-known vintage application for Unix
+systems, based on the X11 protocol. It shows fish swimming over the desktop.")
+    (license (list license:expat license:gpl3+))))
+
 (define-public nyancat
   (package
     (name "nyancat")