diff mbox series

[bug#64905,v4,01/11] gnu: Add rust-path-slash-0.2.

Message ID f25240149ca1233d6b94f1ea3069e9f4f61e1c79.1692539095.git.hako@ultrarare.space
State New
Headers show
Series Update tree-sitter{, -{bash, c{, pp, -sharp}, go, java, {java, type}script, python, rust}}, | expand

Commit Message

Hilton Chain Aug. 20, 2023, 2 p.m. UTC
* gnu/packages/crates-io.scm (rust-path-slash-0.2): New variable.
---
 gnu/packages/crates-io.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 77a41a5116..f91c5db3a9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45806,6 +45806,28 @@  (define-public rust-path-clean-0.1
 path.Clean.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-path-slash-0.2
+  (package
+    (name "rust-path-slash")
+    (version "0.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "path-slash" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0hjgljv4vy97qqw9gxnwzqhhpysjss2yhdphfccy3c388afhk48y"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs (("rust-lazy-static" ,rust-lazy-static-1))))
+    (home-page "https://github.com/rhysd/path-slash")
+    (synopsis "Rust library to convert a file path from/to slash path")
+    (description
+     "This package provides @code{path-slash}, a tiny library to convert a file
+path (e.g. @code{foo/bar}, @code{foo\\bar} or @code{C:\\foo\\bar}) from/to a
+slash path (e.g. @code{foo/bar}, @code{C:/foo/bar}).")
+    (license license:expat)))
+
 (define-public rust-pathdiff-0.2
   (package
     (name "rust-pathdiff")